VM211 Earth Listener - VMA343 Lightning sensor does not report any lightning

Have been running the Earth Listener for a while now at firmware level 3.4.
Recently there were quite some thunderstorms here.
None of them were reported by the lightning sensor.

The sensor is reported in the serial monitor like this:

***AS3935 sensor feedback***
Scanning at address 0x03, please wait...
Scanning complete, I2C device found at address 0x03
Starting setup procedure ...
wrt: 0 Act: 0
wrt: 20 Act: 20
wrt: 0 Act: 0
wrt: 24 Act: 24
Configured used for indoor operation
wrt: 0 Act: 0
disturber detection enabled
wrt: 0 Act: 0
wrt: 9 Act: 9
capacitance set to 8x9
AS3935 manual cal complete
Printing out Reg vals:
Reg 0x00: 36
Reg 0x01: 34
Reg 0x02: 194
Reg 0x03: 0
Reg 0x04: 0
Reg 0x05: 0
Reg 0x06: 0
Reg 0x07: 63
Reg 0x08: 9

Done sofar:

  1. try different values (72, 56 and 112 ) for #define AS3935_CAPACITANCE

  2. Different locations in the house.

Disturbance is not reported either (good sign I think).

This issue is slightly related to:
[VMA343 Lightning sensor missing product info and datasheet](vma343 Lightning sensor missing product info and datasheet)

@velleman Could the VMA343 have some defect, what should I do?

I have the same issue. Where you able to solve it?

Nope. I hope Velleman support can help us.


The value you should use with the EarthListener is 72pF, since that is being used on the board.
Detection of lightning is limited by insulators, such as the case. We therefore recommend to mount the VMA343 sensor outside of the EarthListener. There are small cuts in the case to wire the connectors to the inside. We will update the manual soon describing this option.

We can also suggest changing the setting indoor/outdoor, since the sensor seems to give better readings in the outdoor mode. We are still investigating this and will report in our manual with our findings.

Kind regards,

@VEL342 Thank you Pieter,

Will first try setting “outdoor” because that does not need hardware change. And now waiting for a thunderstorm.
Temperature is high enough.

Kind regards,

On my unit, the problem is the same.
And I tested with a Piezo element from a sigaret lighter.
This should be the same as lightning. However no effect whatsoever.
I’ve seen a movie on Youtube, showing that a spark from Piezo-element has effect.

Setting my Earth Listener to “outdoor” did not help. A few days ago we had a good thunderstorm rather close; no detection registrated.

Hi @bert.test,

Have you tried mounting the sensor outside of the case?
Kind regards,


Hi @Guus.Assmann

If you mimic lightning by using Piezo elements or other devices, we have choosen to hide this feedback from the sensor on the EarthListener. We do this because a lot of devices are giving off small electric discharges. However, if you connect the EarthListener to your PC and have a look at the Serial output, this feedback will be shown.

If you want that feedback shown on the EarthListener, change this line in the code:

Now every feedback from the sensor will be reported. Most of that feedback will fall under category 0: IRQ source result not expected. See tab functions in the code:

If the sensor will registrate too much noise, it will give this warning:
Noise level too high! Move the sensor. (category 3)

Kind regards,

Hi Pieter,

As it happens at the moment I am reconfiguring my Earth Listener to mount the sensor outside the box.
Gives also a simple opportunity to verify once more the connections.
Tomorrow we have another forcast with lighting so fingers crossed that no serious accidents happen and that we get an indication of the lightning.

Thanks for the bump :wink:


Hi @VEL342,

A day later there were lightning showers. As close as ca. 2 kilometers.
No indication on the Earth Listener at all.

Later during the shower I placed the Earth Listener outside the window, like this:

More showers are predicted, so I leave the construction in place unless the wind turns and the device is in danger of getting wet…


Hi @vel342.
Also here, there has been a lot of thunder, but no reaction on the unit.
It doesn’t have to react to any electric discharge.
But it should react if there’s real lightning.
Right now, it seems that there’s never any reaction.

My forecast says there will be thunderstorm around 1 AM then I can way if my weather station detects any lightnings.

Showers with lightning have past (not far away) but no indication on the Earth Listener.
The situation was as the previous photo, running version 3.4 final.
What next (apart from waiting for more lightning)?

Same problem here…there was thunderstorm at night but my station did not detect any lightnings.
What could cause the problem?

@Guus.Assmann, @bert.test @Pz83 did you mount the sensor outside the casing?
Kind regards,


Yes, see post10: VM211 Earth Listener - VMA343 Lightning sensor does not report any lightning

Even placed the unit at the outside of the window see picture in post 11

Kind regards,

Yes, the sensor is mounted at the back of the casing and visable.
However, if it’s that important, the sensor is not sensitive enough.
The house would shield too much, glass windows, concrete, wood etc may shield the fields.
How does my radio work inside my house?
In other words, I think the software has some filtering or a bug.

I had mounted lightning sensor outside the casing and I turned on the weather station.

  1. Mounting:
  2. Starting-up:
  3. Main Screen:
  4. Disturber:
  5. Settings:
  6. Jumpers - My question is if the jumpers should be on or off the lighthing sensor?

Now I am waiting for next thunderstorm.

1 Like

Hi Pieter @vel342

Pitty the source changes are presented here as a picture.

A bit hard to copy / paste those changes.
Is it doable to show those lines as text?

The weather tomorrow predicts possible showers coming from Belgium to the Netherlands. Maybe I can implement it tomorrow morning.