Vertex Delta K8800 - Marlin Firmware 2.0.7

@Hitch Did you clone @SusisStrolch repo from Github and switched to the K8800 branch?
Changed VELLEMAN_K8800_STOCK to true in Configuration.h? (assuming you got a stock printer)
I also installed the extension “Auto Build Marlin” in VSCode, makes it easier to build/upload.

Yes, download is named “Marlin-K8800-2.0.x.zip”

No, because I have a heatbed installed . But it should build correctly in both configurations, or?

I now installed that also, but no change in result…

@Devrope I installed ““Auto Build Marlin” but I didn’t use ist …

Now I found out how to use it and it worked.
Unfortunately I can try the FW on my printer earliest at the end of the week.

And I still have to look which heatbed configuration is correct one for me.

Thanks a lot!

1 Like

So, if you have a stock K8800 with only a heated bed mod it’s sufficient to set
#define VELLEMAN_K8800_BED 1
and set the HEATER_BED_PIN, TEMP_BED_PIN, TEMP_SENSOR_BED according to your pinout.
The comments are only a reference to implementations known to me.
I used the “3” only to distinguish my configuration to compute some settings during compile time, anything else isn’t checked at all.

VELLEMAN_K8800_STOCK=true is only to bundle larger modifications (like extruder, rods, some settings reflecting my opinions about speed and calibration).

Thanks for the answer. :slight_smile:

I found out yesterday already and adjusted the settings according to my printer.

The FW seems to be running. I still have to adjust the PID settings of the heatbed and then I’ll start a testprint.

What I noticed: After the first time flashing, the display was much too bright and could not be turned down.
Then I tried a different display selection. This did not work. But when I switched back to the old display selection and flashed it again, the display worked properly.

Yes, the display is a bit strange. Never found why it needs a “bootstrap” to work properly.
Maybe there’s a setting in EEPROM which isn’t initialized after the firmware change.

I thought I changed the contrast settings to some moderate value.
So you switched back to the AZSMZ_12864? Or did you use the display type from Velleman?
Because the latter had a problem by rotating the whole screen by 32lines.

thank you for this, a lot more features/options with the 2.0.7 firmware coming from the 1.1.4.
some major differences is the calibration and default startup sequence but also it seems to be making more noise.
is this possible? i selected just the stock k8800 option, i don’t have those fancy mods (yet) :slight_smile:

More noise - during homing, calibration or in general?

sorry for the late reply @SusisStrolch the noise is overall present, but when the head is going down, it is really really loud.
I have created a youtube video so you can hear a bit of what I mean. https://www.youtube.com/watch?v=wm0Cz8mXdmU

any idea? I’m printing a lot these days and the printer is in my home office :scream:

edit: I made another video while printing https://www.youtube.com/watch?v=Z-Aigzor9Qc

Still getting compiling error. Using marlin version 1.8.8

How did you compile?? I’ve got still compile error

Hello @Editortje
To compile Marlin, have you try https://platformio.org/ , or https://marlinfw.org/docs/basics/auto_build_marlin.html some VSCode Plugin ? cause Arduino IDE seem to have some dificulties to do it …

platformio works better, what are the errors you are receiving?
there are a lot of guides online on how to compile the marlin firmware

1 Like

The only error is compiling error. No more details

This firmware is only i hou have heated bed and bltouch . Standard

This firmware is only i hou have heated bed and bltouch.

Read the source, Luke, before spreading nonsense.
In Configuration.h:

// set to true to use settings from Velleman K8800 Marlin 1.1.4
#define VELLEMAN_K8800_STOCK false

And, because we are about READING…
The Marlin Webpage shows in big letters that 2.x will not compile with Arduino IDE and you MUST use platformio to build the firmware.

3 Likes

Hey @SusisStrolch, I did not see your topic… I modded Ug8lib-HAL to comply to the Velleman’s K8800 screen…

Use it if you want to go back to stock screen: Marlin 2.0.7.2 with screen fix - Vertex Delta - Whadda forum - Community Help and Support

Let me know, so I can delete my topic

Hi @Psycho, thanks, but I won’t support Marlin any more.
Together with @11to3 we‘re going the Klipper path, which looks already pretty promising.

Hi @Psycho,

Thanks for your upgrade fix for original stock display in Marlin 2.0.7
It works great. well done :+1:

But i’ve have one question. I see that the “Delta calibration” menu has disappeared.
or not the same as in Firmware 1.1.4.

But when perform a delta calibrate with Marlin 2.0.7 i have Probing Error. the printhead does not touch the bed while probing (it stops few cm above bed and display shows: Probing Error).

And that was not with 1.1.4. Vertex Delta works fine on 1.1.4.

But i want to use the latest Firmware 2.0.7. So I can use more functions implemented in the latest Marlin firmware such as: Status leds (Neopixel leds), Print last SD file, scroll long file names and so on. There were also some bed leveling bug fixes.

I’ve tried also the 1.1.9 firmware. But same probing error as in 2.0.7.

What do i wrong, or is this a fault?

Thanks in advance.
Best rergards,

Onlydreamer

@Onlydreamer usually it’s a M851 issue, you have an offset in there and the probing fails because it starts too high and stops after 10mm

Also, the delta calibration is still there, once you have homed though. Then it’s in the control sub menu

1 Like