Vertex Delta K8800 - Marlin Firmware 2.0.7

Marlin 2.0.7 firmware available on my github page.
Vertex Delta K8800 - Marlin 2.0.7


How do you install the new firmware on k8800?
I can find any documentation how do it?

This is not an official Welleman firmware. You need to build it yourself from source code.
It’s based on Marlin, so the instructions found here applies:

As @Devrope mentioned you have to compile it yourself, connect via USB to your PC and upload the firmware.
Because it’s still work in process and I didn’t get any feedback I’d recommend that you
a) have the fall-back firmware from Velleman around (by reading out the flash rom, because - sadly enough - @Velleman isn’t able to provide the original 1.14 hex-file, nor giving some comments / tests on newer firmware).
b) some knowledge in hard- and software

1 Like

@SusisStrolch The K8800 Firmware Downloader from Velleman will flash to stock firmware, it just needs Arduino to be installed. I’ve used it when I tried your 2.0.6-firmware and I got problems.
Today I’ll try 2.0.7 on my stock K8800, will report back here when done.

@SusisStrolch No issues so far, calibrated and printed a Benchy. :+1:
But then also no big difference from the stock firmware, maybe a little less stringing.
I did use a color I haven’t used before (but same brand) so I can’t be sure.

@Devrope It’s first Time for me using Platformio.
Installation seems to be fine, no errors.
But when i try to build, i get an Error:

Executing task: C:\Users\Hitch.platformio\penv\Scripts\platformio.exe run
Processing K8800 (platform: atmelavr; board: megaatmega2560; framework: arduino)

Verbose mode can be enabled via -v, --verbose option
PLATFORM: Atmel AVR (2.2.0) > Arduino Mega or Mega 2560 ATmega2560 (Mega 2560)
HARDWARE: ATMEGA2560 16MHz, 8KB RAM, 240.00KB Flash
DEBUG: Current (simavr) On-board (simavr)

  • framework-arduino-avr 5.0.0
  • toolchain-atmelavr 1.50400.190710 (5.4.0)
    Converting Marlin.ino
    LDF: Library Dependency Finder ->
    LDF Modes: Finder ~ chain, Compatibility ~ soft
    Found 6 compatible libraries
    Scanning dependencies…
    Dependency Graph
    |-- 0.4.3
    | |-- 1.0
    | |-- 1.0
    |-- 1.0
    |-- 1.0
    |-- 2.0
    |-- 1.0
    Building in release mode
    Compiling .pio\build\K8800\src\Marlin.ino.cpp.o
    Linking .pio\build\K8800\firmware.elf
    avr-g++: error: CreateProcess: No such file or directory
    *** [.pio\build\K8800\firmware.elf] Error 1 <

Do you have a hint for me?
I reinstalled python, vscode, PlatformIO and also the Marlin code serveral times, but no change.

@Hitch Did you clone @SusisStrolch repo from Github and switched to the K8800 branch?
Changed VELLEMAN_K8800_STOCK to true in Configuration.h? (assuming you got a stock printer)
I also installed the extension “Auto Build Marlin” in VSCode, makes it easier to build/upload.

Yes, download is named “”

No, because I have a heatbed installed . But it should build correctly in both configurations, or?

I now installed that also, but no change in result…

@Devrope I installed ““Auto Build Marlin” but I didn’t use ist …

Now I found out how to use it and it worked.
Unfortunately I can try the FW on my printer earliest at the end of the week.

And I still have to look which heatbed configuration is correct one for me.

Thanks a lot!

1 Like

So, if you have a stock K8800 with only a heated bed mod it’s sufficient to set
#define VELLEMAN_K8800_BED 1
and set the HEATER_BED_PIN, TEMP_BED_PIN, TEMP_SENSOR_BED according to your pinout.
The comments are only a reference to implementations known to me.
I used the “3” only to distinguish my configuration to compute some settings during compile time, anything else isn’t checked at all.

VELLEMAN_K8800_STOCK=true is only to bundle larger modifications (like extruder, rods, some settings reflecting my opinions about speed and calibration).

Thanks for the answer. :slight_smile:

I found out yesterday already and adjusted the settings according to my printer.

The FW seems to be running. I still have to adjust the PID settings of the heatbed and then I’ll start a testprint.

What I noticed: After the first time flashing, the display was much too bright and could not be turned down.
Then I tried a different display selection. This did not work. But when I switched back to the old display selection and flashed it again, the display worked properly.

Yes, the display is a bit strange. Never found why it needs a “bootstrap” to work properly.
Maybe there’s a setting in EEPROM which isn’t initialized after the firmware change.

I thought I changed the contrast settings to some moderate value.
So you switched back to the AZSMZ_12864? Or did you use the display type from Velleman?
Because the latter had a problem by rotating the whole screen by 32lines.

thank you for this, a lot more features/options with the 2.0.7 firmware coming from the 1.1.4.
some major differences is the calibration and default startup sequence but also it seems to be making more noise.
is this possible? i selected just the stock k8800 option, i don’t have those fancy mods (yet) :slight_smile:

More noise - during homing, calibration or in general?

sorry for the late reply @SusisStrolch the noise is overall present, but when the head is going down, it is really really loud.
I have created a youtube video so you can hear a bit of what I mean.

any idea? I’m printing a lot these days and the printer is in my home office :scream:

edit: I made another video while printing

Still getting compiling error. Using marlin version 1.8.8

How did you compile?? I’ve got still compile error

Hello @Editortje
To compile Marlin, have you try , or some VSCode Plugin ? cause Arduino IDE seem to have some dificulties to do it …

platformio works better, what are the errors you are receiving?
there are a lot of guides online on how to compile the marlin firmware

1 Like