Scratching surface when travelling


I’m new here and to 3d printing as well. Been through a lot of reading. I bought myself the Vertex Delta and mounted it. Wasn’t hard, nice hardware. I did manually wear in the brass on the sleds, as I am a precision mechanic, I know these things need some travelling first for natural adjustement.

Printed the demo logo, everything went fine, nice looking. I followed the instructions and changed the filament in the middle, it worked, it is just slightly offset.

Anyway… Now tried to print 3d benchy without success. Three time already, after a while, the print crashes in the model.

I also noticed that the print, when printing a surface, does an end, and to travel to another end, at the same layer, it doesn’t move on Z, resulting on the nozzle scratching on the model surface… How do I prevent this?

I am using Vertex Delta repetier, CuraEngine as slicer


This text will be hidden

These are just guesses since I can’t see your printer.
Do you have the end stops in the correct location?
Since you printed the logo without a problem and then they started.
The cups on the rods that hold the magnetic balls.
Check to see if they are coming loose.
I put plumbers (Teflon) tape on mine about 4 wraps.
I missed one and it came loose yesterday.
The others are holding well.

Thanks for your reply! I took extra care of all the screws in the kit and used loctite 243 on most of them

One thing I have never used before is the PTFE coating. Bought a spray bottle in the local store here and applied it. No idea how to apply it nicely and how it is supposed to look after coating

The surface running also occured on the logo model. Isn’t there an option to elevate Z when travelling and not printing? I mean it’s gcode, would be easy to do (I’m a cnc programmer…), but tedious knowing the amount of lines…

As I have simple no idea how to properly apply PTFE in spray form evenly on the surface of a magnetic ball (imo, impossible if you want to be precise) I decided to unmount all the sockets and coat them, which is much easier. Will see what this brings in term of precision

Still, this won’t solve the surface scratching

Especially on delta printers, as these have a very fast moving Z-axis, it’s common to activate “Z-hop” - it’s the lifting of the head, on each retraction action.

This will result in the head being lifted off the piece, while travelling. In repetier host, you’ll find this setting on the “extrusion” tab page. A value 1 to 4mm Z-hop height should solve the issue, I think?

I don’t have the Vertex Delta, I’m using an Opiliones L2 delta printer myself. But I’m sure Z-hop will sort this scratching issue out for you.

1 Like

Unfortunately I have had a hard time finding the PTFE spray.
I did find some Teflon spray.
I cut down a plastic cup and sprayed some it there and then remove the magnetic balls and roll them around in it and reinstall them depending how much I print I do this often.
Also make sure all of the rods the the hotend slide up and down on are clean and oiled.

Just by the name of the setting I can say that’s what I’m looking for! Gonna give it a try in a moment. I had 0.2 in it, gonna raise it! Thank you very much!

It doesn’t change the fact that when printing a layer it travels on it without retracting

I can’t fully understand the scenario. You write that, while printing, it travels on a layer without retracting…

If you see the printer ending a line - then doing a retraction, in order to move to the next starting point: does it raise the head, as instructed in the Z Hop setting? Or not?

If the nozzle needs to travel on the printed layer, while not extruding, there isn’t always a retraction command given: some slicers don’t regard stringing inside the object as an issue, so in those cases a retraction command then isn’t issued - therefor, the Z Hop isn’t executed either.
(A problable reason for this is, that intensive retraction is prone to cause nozzle blocks - so some slicers try to minimize retraction, where possible).

Some slicers, like Simplify3D, allow you to force a rectraction between layers. I can’t find a comparable setting in Repetier with Cura. I’m not sure, if you can solve this. You’d need to find someone who’s very familiar with the standard Vertex delta slicer.

Edit: For clarity, I’m using Simplify3D on both my Vertex K8400 (cartesian) and Opiliones 2L (delta): on my model delta printer, I do see the behaviour of the nozzle lifting during travel.

Exactly, it travels full speed over the layer, scratching the surface

See those yellow lines, they are fast travels, but they do so without retracting at all

Z-Hop is set. I’m using Repetier’s Cura to slice, the gcode is then saved on my raspberry directly and the print is managed with octoprint

And it is scratching every layer, right? That has to imply, that a retraction command isn’t given on the layer change, in Repetier / Cura.

I’m not familiar with a general g-code command, you could include in the start script, that could override this behaviour and “force” retraction on layer change…

I would think, though, this behaviour could be embedded in the machine’s configuration… but that would mean altering the standard Marlin implementation - I wouldn’t go there, unless you have no alternative: too easy to ruin the machine. :wink:

I would suggest to take this to Velleman’s Vertex delta support team, to see if they can help you.

Otherwise, you might want to find a Vertex delta user, that uses Simplify3D and see if that would solve the issue for you?

Edit: There might be other free slicers, you can also try… Simplify3D is a bit too expensive to buy without first testing if it solves your issue…

Hope this helps…

It is retracting on layer change :), but not when working on a specific layer. Say it fill a circle, it odly starts somewhere in the middle, goes in lines to the right of that circle, the lines get smaller and smaller till circle right outer perimeter reached. It then won’t retract, but travel over what it just printed, to reach circle middle again and print the filling towards the left outer perimeter

I understand. Seeing your settings & assuming that travel distance you describe would be more than the 4.5mm shown above, one would prefer (& expect?) to see a retraction there.

Mind you, my Vertex K8400 is doing this the same - so, it might be part of the way Velleman is setting up their printers…? For a delta printer, making this nozzle lift movement is much simpler - a cartesian would have a lot more wear on the Z-spindle’s threads, hence it’s often omitted for cartesians.

i know you understood but I just wanted to share a real photo of that said problem

Ok, this is first layer, it will be hidden. But it will do it to the last layer! And I doubt it’s very good for the nozzle itself and the coordinate system as it induces a vibration that might move the axis slowly

Thanks for the photo, that does help.

Especially on the top layer, the scratching doesn’t look good - I totally agree, that you should have a way to work around that.

As far as I can recall, the Vertex K8400 doesn’t cause scratches like this - every now & then, you can see a little trace - but nothing as significant as this…

I don’t expect that the nozzle will not have any noticable wear from it, though - but that’s not even that important… The fact that the print is being damaged is important, especially when it’s the top layer. And on tall builds, a friction like this could topple the print over & break it loose from the print surface.

I’d suggest you should try to bring this to the attention of the developer team… see what they can do for you. [crosses fingers]

Have you tried to recalibrate it?
Did you check the piezos

Many times recalibrated. The prints look good, no problem there. If it wasn’t calibrated correctly, the first layer would have problems or the whole structure would.

Yesterday this surface running did rip off a center piece that ruined a 7 hours print (ok, I was only mid way, but still)

The scratching is always a little present, but it should never interfere with the printing process or break a piece of your model. Are you sure the belts are tightened equally and enough? A loose belt can be the cause of this as the head will be at a lower position during travels than the software thinks it is.

I do not mean you need to crank the tightness of the belts way up but make sure they are properly tensioned.

when you move the sleds manually do you feel any resistance, especially between the different towers, like one is more difficult to move than another?

You can indeed increase the Z-hop variable in the slicer settings but the factory setting should be fine.



The belts are pretty tight, like, a belt should be (precision mecanician here) Can’t play guitar with them though, so, normal…

The towers have been aligned properly within a few 0.01mm and the sledges feel great when moving. Been working them very long with honing paste and cleaned them many times. They are fully adjusted now.

I don’t really get it though, because when I’m programming my CNC I make sure to have a z lift before travelling over a surface

Increasing z-hop setting does nothing in this case, it hops between print surfaces. It doesn’t hop when travelling from one point to another on the same surface

Increasing z-hop setting does nothing in this case, it hops between print surfaces. It doesn’t hop when travelling from one point to another on the same surface

Z-hop is executed together with a retraction command. When travelling within the same surface portion, a retraction is not requested by the slicer software. (I’m pretty sure that this is the case in most slicers: Repetier (with Cura engine) & Simplify3D are handling this the same, in any case).

@VEL327 Would there be alternative methods available to trigger the exuction of Z-Hop on head travel?