PCS500 "no hardware response" error


I am running PClab2000se 3.1 on Windows XP SP3 logged in as administrator and trying to connect to a PCS500 scope on LPT1 with an address of 378.

The problem is when I start up the software it gives me the “no hardware response” dialog but the power LED comes on and when I close the program it turns off, so it is talking to the scope. If I click “run” it will read the scope. When the program is reading from the scope there is quite a bit of noise, 2.5Vpp and other other times it is a straight line with a DC offset of -7V. I have tried to calibrate it but it just returns the same “no hardware response” dialog error so I can not calibrate it.

I also have tired uninstalling, deleting the program files folder, deleting the .ini file, deleting the DriverLINX driver from device manager and reinstalling it. I have tried powering the scope with a bench power supply.

Why if the software is talking to the scope am I getting the “no hardware response” dialog?

Thank you,

It seems that there is now the same problem you had two years ago:

The solution was…?

At that time I had to send it back for servicing and it worked after they fixed it. I have not used it in at least a year, I know a lot more about electronics now that I have finished EE school since that time. I could probably fix it myself if it is a hardware problem, can you guide me in the right direction on what to check.

I hope you have the CD to find the circuit diagram and PCB lay-out drawing.

You may start by checking the -5V supply at the output of IC1.

I lost the CD after I have moved so I no longer have the circuit diagram, etc.

I found these files in another thread: vel255.diinoweb.com/files/PCS500_operation.zip
Is that the most up to date schematic and layout?

Edit: I checked the -5V & 5V regulators, they are okay.

OK you found the document package. It is up to date.

Strange problem - indeed.

Sorry - I do not have a clue what might be the cause to this problem.

You may try to locate it yourself or send your scope to repair…

It’s been some time since my last post. I checked all the basics like power supplies etc but there is not much I can do without a working scope to troubleshoot further. It may be a broken or damaged opto or something on the interface side. It’s a shame I have to send this off again but where can I find a repair center?

I wanted to give an update for anyone who comes across this thread who has the same problem as me. I went through sending the unit back through RMA only to find out that I was using too long of a cable. I have tried three 6ft IEEE-1284 cables before I found a 2-3ft cable I had (probably the cable that came with the unit) and it worked!! I have not found a longer cable that works so this unit is very sensitive to cable lengths.


Ive got no problem with my cable, its 1.80 meter.
so maybe it’s a combination of parallel port, cable quality and scope.