K8203 extruder not feeding

I installed a K8203 extruder, which went well.

However, when I try to print, the extruder motor makes clicking noises, the filament moves up and down, but nothing is extruded. When I manually heat up the extruder, I can push filament through the extruder.

I worked exactly according the manual, cut an exact 23 mm of the white tubing, uploaded the new firmware, and installed (and checked) the new Slicer configuration file. I checked the voltage on the driver, which is 0.896 V, which should be OK

Whatever I try, the extruder is simply not feeding, only moving filament up/down?

Could it be that the spring is too tight? I can hardly squeeze the spring handle manually?

Any help would be appreciated.

You may need to check the alignment of the pulley on the motor
Also check the screw that hold the pulley on to the shaft.
If it loose it will do this.

Thanks Wrong-Way,
I’ll take it apart tomorrow and check.
Still strange that the filament does move up and down.

From that description it makes me thing the pulley is snug on the shaft but not tight.
At this point this is my best guess.

You should also check the control voltage setting on your stepper driver. The DRV8825 has a higher Vref setting than the original A4988. In any case, you might boost the voltage slightly to see if it helps.

The spring on the 8203 is very strong. I sometimes have to use pliers to activate the lever. That is fairly normal.

I have had the 8203 jam like this in a few cases:

  • When switching from ABS back to PLA, make sure no material is clogging the extruder.
  • Make sure the teeth of the gear do not have bits of plastic gumming it up.
  • Make sure you aren’t printing too close to the bed. If the head is too close, the plastic can’t get through the extruder. (Does it work if you raise the print head?)

There could be other electrical problems, but I would start with these first.

Dr Vegetable

Did you see the load latch for the K8203 K8400 and the K8600?
This makes it easier to load the printer.
Very quick print.

1 Like

Wow, I had not seen that. Thanks for the link! I will definitely print one of those for each of my K8200’s.

Thanks to you all for your suggestions.

I took the 8203 apart and have completely rebuild it. Still the same problem. I could easily push filament trough the extruder, but printing did not work.
When I tried a feed with the Repetier software (latest version) I noticed that the feeding appeared to be in the wrong direction.
So I changed “INVERT_E0_DIR” from true to false and this did the trick, the 8203 is working perfectly.
I checked and rechecked the wiring, did this is all according to the assembly instructions. So I don’t know what is causing this behaviour, but the unit is working anyway.

Ah, that makes sense.

The 8203 can be built in either a left-handed or right-handed orientation which makes it more suitable for use in a dual-extruder configuration. The instructions show how to build the left-handed version, which requires the motor direction to be reversed in the firmware. The directions mention this briefly, but not in great detail.

Thanks for reporting back, and happy printing!


Nice setup you have with the two extruders. I was looking for something like that (in due time), in order to print support material.
Which controller board do you use for this, as the standard K8200 board cannot accommodate another extruder (nor another heatbed, as I was looking to use two headbeds for the 40x20 extension).

Thank you!

I replaced the stock controller board with an Arduino MEGA 256 with a RAMPS 1.4 shield attached. You can get these very inexpensively on ebay.

I did a detailed write-up about how to perform this modification. It seems that there is some problem with the image links that I posted, so I’ll see if I can repair them somehow.

I hope you find this useful.

Dr_Vegetable: Your the man.