K8062D.dll and C program ?


I would like to check if I can use K8062D.dll in my development environment : mingw-w64 (gcc), C langage, Windows 10 Pro 64bits, in order to control lights with my own software and DMX protocol.
As there are no files dedicated to my configuration in the k8062 sdk, I tried with those of the ‘Borland C++Builder’ directory, but when I compile a short test program and link I got the message
‘K8062d.lib: file not recognized: File format not recognized’
I tried to build a K8062d.lib file with the dlltool utility but I didn’t succeed, the linker ld sends a ‘undefined reference’ message for each call to a function of the dll.
Does somebody know a version of the sdk which could work with my configuration ? It would be of great help for me.

Thanks in advance !

Hello @jyb46

Mybe this help you further,



Version 3 dll source file and the .lib file:
Here you can download v3 dll together with the .lib file:

Best Regards,
Velleman Support

Hello VEL450,

Thank you for trying to help me! I’m sorry but my problem still remain:

  • the two .zip files you gave me the links are the same I already tried to use, with the of course the same error messages,
  • regarding the two files downloaded from box, that’s to say K8062D.dll and k8062d.lib, they are more recent than those of the sdk, but unfortunately I get the same message:

K8062d.lib: file not recognized: File format not recognized

That’s where i am…

It seems that you are using 64-bit compiler to generate 64-bit code.
The DLL is a 32-bit file and it is not compatible with 64-bit compiler and maybe also with the dlltool you used to build the lib file.
In this thread there is some info and a link to download the 64-bit DLL version:

I tried the dlltool to generate the .lib file.
Here you can download the 64-bit K8062D.dll, K8062D.def and the generated K8062D.lib:

Here you can download the package containing 64-bit demo software together with all the required files to test:

You were right: the problem was my 64-bit system . With the last generated files you sent me, i can compile and link normally, i obtain a .exe without error message.
That’s what i wanted to check.
Thanks a lot!

No problem. Glad to hear it’s working now.

Hello :smiling_face_with_three_hearts:

As per my knowledge, Given your setup with MinGW-w64 (GCC), C language, and Windows 10 Pro 64-bit, you’re correct that the provided SDK files for Borland C++Builder might not be directly compatible. I think you need to Generate the Import Library and Create the Import Library.

I hope this will help you. :innocent:

Respected community member :smiling_face_with_three_hearts:

Hello kate44.
Thank you for attention and tracking. You’re certainly right, however one of your collegues did that work for me and sent me an import library and a dll which work fine, so i could write a C program which uses that dll and do correctly the job. For me the problem is solved.
Best regards.