K8048 programming problem (USB to Serial cable?)


I’ve just purchased a K8048 kit and It all works OK from my desktop PC with a real built in COM port.

However when I connect it to my laptop with a USB to RS232 dongle I always get write verification errors on the first instruction word. I’ve tried adjusting the speed setting in the procpic2 software to “very low” with no luck. I’ve also moved back to the desktop machine and programmed exactly the same hex file with 100% success.

Any ideas?


Because our programmers K8048 (VM111) and K8076 (VM134) doesn’t use the standard RS232 protocol, a USB converter can not be used.

As most new machines (including desktops) are these days supplied without a COM port, many people will have to resort to a USB to RS232 adaptor (such as the prolific one that I use).

I think you should mention on in your product litrature that this sort of COM port is not supported.


At the product page of this kit is written:

not compatible with USB to serial (RS232) convertor !

Such cable can not emulate handshaking lines w/o “timing jitter”

Anything that can be done about this? I’m having the same problem.

And it says it nowhere on the actual kit. :frowning:

No, I’m sorry. Such cable is not a real RS232 port.

Don’t know if this may help, I had a similar problem with a USB converter, the solution I used was a Bluetooth to RS232 Serial Adaptor.
You can use the USB to RS232 (Prolific) converter to configure the adapttor to be a true RS232 interface, via the standard Hyperlink Terminal.
Then use a standard USB Bluetooth adaptor in the PC with a virtual com port driver, but the business end (that plugged into the equipment) saw a real RS232 comm port, complete with all its hardware handshaking etc.
These are availabe from LM Technologies Ltd. (Birmingham, UK), I’m not sure if they have a website, but if anyone is interested in further details, post a listing with a contact email address, and I’ll send you further details.

hello i am wondering if i could find out more about the bluetooth to RS232 converter to talk to the K8048.

The unit’s manufacturing details are :
LM Technologies Ltd.
66-68 Hagley Road
West Midlands
B16 8PF
Tel: 0870 066 2740

The contact names I have for them are:
Michael Sims
and ‘Andreus’ … sems to be the technical engineer.

When I purchased it in 2007, it was £39.99 including P&P.
The only drawback (if you can call it a drawback) is that it has to be configured by plugging it into an RS232C serial port (It does configure ok with a USB to Serial adapter cable), this is to allow you to change the RS232 settings from the factory defaults, and also ‘synchronise’ with your Bluetooth devices.
I have found it very good, and reliable.
Hope this helps … good luck.

I’m sorry but there is no good alternative, the programmer doesn’t work stable w/o real RS232 port. for users that only have a USB port we can offer now the new USB PIC programmer PICKIT2 wish is also Microchip MPLAB compatible.

I’m currently in the middle of a important uni project which involves learning how to program PIC’s. I bought the k0848 last week and built the thing only now to find out, after i bought it, that it doesn’t work with usb to serial cable. I’ve just wasted days trying to figure out what I’ve been doing wrong, when in actual fact, I haven’t been doing anything wrong at all. I think its very irresponsible of Velleman not to mention anywhere on the actual product that its not compatible with a usb/serial converter especially since most people don’t have the serial ports on the newer computers.

I’m just wondering, how many other people have had the same problem!

I am now in a position where I have no money to buy the newUSB version of the kit. I now have an absolutely useless piece of kit that has taken the last of my money and more importantly, most definitely going to fail my assignment!!!

I’m another user who is dissapointed with the lack of detailed info on the reason why prolific USB converter doesnt work with Velleman software. I see “8048 present” message, “erasing” and then a failure to verify the first data block. With correct handshaking surely timing is not critical.

As there are obviously many loyal customers with the same issue might I suggest Velleman release the source code as after all RS232 is legacy hardware and many companies like Maplin continue to sell the VM111 with no indication (external on the box before it is opened) that it cant be used with most current laptops - this isnt really fair.

I like velleman products and would continue using them but more support would be very much appreciated, I think it would help satisfy those of us who otherwise would be forced to buy another converter / learn linux or scrap the boards we have just purchased and put it down to experience.

Best regards - Chris Baxter


On the package of our programmer is written: free serial RS232 port required !
An USB rerouted type is NOT an RS232 port !
A converter just generate a serial signal, but our programmer doesn’t use RS232 protocol, so that’s the only reason
why it doesn’t work.
For people wish haven’t a real serial port we have now the original microchip’s PICKIT module.

I hope it’s now clear for everybody…

I have tried using a USB to RS-232 cable (VS com). I can read programs using this but cannot write them. Using the program debug on http://dev.kewl.org/k8048/Doc/ I can see the sent data. So it is possible to use the non-serial protocol with a USB to serial converter but burning chips doesn’t work. Since communication seems to work (to read the chip one must both send and receive) my theory is that burning doesn’t work due to low voltage. Maybe one could fix this by changing some resistors on K8048/VM111.

Contrary to the postings here, I’ve had a completely different experience with the USB-Serial dongle I’m using. I have a kit which has “P8048’1 ©Velleman KIT, 2003” - I’m not sure if this is the exact same as the K8048 kit.

But I have no problems with programming the 16F627 that came with it except for the odd write error using the Velleman PIC programmer (Rev 2.6.0).

The cable Im using uses COM4 on my Acer Travelmate laptop running Windows XP SP2.

That’s the same board that I have.

You say you can program it but that you have a write error. What do you mean? Does a downloaded program work despite the write error? Does it work with some other programmer than Velleman PIC Programmer (Rev 2.6.0)? What USB to RS-232 cable do you use?

When using the Velleman PIC Programmer (2.6.0) I sometimes get a write error - it comes up with a message similar to:

Wrote: 00E7
Read: 0000

So the programmer appears to be reading back what it has written to verify the download.
When this happens I just start the download again from scratch. I’ve never had a write error twice in a row.

I havent used any other PIC programmer software yet.

As for the brand of USB-Serial Interface I’m using, Im afraid I brought an unlabeled type off a local auctioning website. The CD-ROM that came with the drivers indicates its a “H L USB Driver”…most likely a cheap rip-off.

But it does work, and I have successfully programmed the 16F627 repeatedly, although to download the “demo2.asm” into the pic takes approximately 3 - 4 minutes, its quite slow.


Ive been having the same problem.
Im using this USB cable converter with chip Prolific PX2303 i think, and the cable says on it: u232 p9

With Velleman progpic2 v 2.6.0, I could program the pic with simple code only (demo1.asm), sometimes getting errors, to program pic with a bigger one, Im having tough times (demo2.asm), no success.
-When I used latest version of Vellemans progpic, it doesnt work at all

I also tried another pic programming software like WinPic, Icprog, and PicProg2009


had luck with PicProg2009!

you can get it here:

or here:

I have no idea why, its not supposed to work, as advised by Velleman, but it does, maybe because it verifies while programming and when verification is not correct, it repeats until it is correct? no idea…

Now i could program the k8048(pic16f627) with bulkier code, like demo2.asm. I tried this several times and still works…

In picprog2009 you have to configure hardware delay to 10, otherwise it doesnt have to work (says the settings does not match the pic…). My settings on emulated port are defaults, looks like it works with any…

*I noticed the progpic2 2.6.0 behaves differently on my laptop x desktop - doesnt work at all / does. Will see later if all of this is going to work on my laptop

good luck


Just to update myself,
what I said above worked on one pc, on other 3 didnt. Have no clue why, all of them have USB2. Same OS or not, doesnt matter.

So I gave up and bought PICKIT2.
Now this is maybe 20x faster than the previous method, takes just 5 sec to upload the program


The problem is even worse than lack of a serial port. This device does not work on my laptop serial port, but does on my desktop port. The excuse given for this was that laptops don’t have a “real” RS232 serial port!!! Please.

I have written a dozen programs that send and received data on this port using normal serial port code and it works fine.

I agree with earlier posts that Velleman should release the code and let us come up with a work around (that we would share) as a fix. I know it can be done.

This is not what I would call Customer Service.

But I also gave up on this and bought an ICD2 programmer which works flawlessly, serial or USB…on the same laptop that Velleman’s doesn’t.