First print and first questions

Hello everyone, I have just finished building my K8200. After that, my first print was 10x10x10 mm cube. While printing, I got some questions:

  1. I noticed the wobble in the Z axis. I read, that it is common issue with these printers. Would changing motor mount would fix the wobble, or do I have to change the Z axis coupler and the spindle also? I add the video: …

  2. Uneven printing bed. As I noticed, my printbed is bent outwards the center (middle of the bed is higher than the edges). Would adding the flat mirror on the surface solve the problem?

  3. Dripping plastic from extruder after printing. Is it normal? After I finished my printing the plastic keeps dripping from the extruder for about minute or so. Is this normal?

  4. Just while writing this, I remembered I forgot to trim these screws out, while assembling the extruder. Is this part necesary?

That is it for now, thanks for the answers.

There are some parts that other have made and things you can do to help the Z wobble
If you go to the link below there are some instructions to help the bed.
More then likely a glass plate will help.
The dripping plastic is normal
You can turn the large gear on the extruder back a little (not to far) to stop that
I let mine drip and clean it as it cools
The last question is important.
You should really file those down.

This is a nice printer but some improvements are required to make the quality of the printed objects way better.

I don’t understand why Velleman isn’t supplying the flex coupler, and better pulleys.(maybe even the gt2)
Those are the most critical parts to upgrade in my opinion.

It could be an add on to the original printer so that the already fabricated and shipped printers do not need to be exchanged.

But hey, its a hobby printer. I find it nice to work in the printer.

Hi Linas_capas,

  1. The z-motor holder improves the quality a lot. I installed mine together with the flex coupler.

  2. Most users have had this problem, and most of them have a mirror or glas plate installed. You can say, it is a “must have”.

  3. Dripping plastic from extruder after printing is normal. Just be sure to have it removed before you start your next print. Otherwise a “nose” of cold and hardened filament could hit your printing bed.

  4. Yes, you really have to file this screws down.

Have fun with your printer,



Thanks for quick replies. New prints, new questions. :slight_smile:

Any tips, how to properly calibrate the printer?

Edit: I use the method for calibrating the extruder, but I can’t get hollow cube, even after I made fill_density = 0.0. What am I missing?



have you already calibrated your printer’s E steps/mm? This should be done before adjusting the multiplier.
The example you tried to print is not optimal for your printer. The values there are for a printer with a smaller nozzle diameter. If the cube is not hollow you could check if you have set the infill density to 0.0. Check your parameters in the G-code window. It happens often, that changes are made on one profile but the object is sliced with another. In the g-code window you can check the actually used values.

good luck



have you already calibrated your printer’s E steps/mm? This should be done before adjusting the multiplier.
The example you tried to print is not optimal for your printer. The values there are for a printer with a smaller nozzle diameter. If the cube is not hollow you could check if you have set the infill density to 0.0. Check your parameters in the G-code window. It happens often, that changes are made on one profile but the object is sliced with another. In the g-code window you can check the actually used values.

good luck


No, I have not, I will try to calibrate steps/mm first, thanks.

Edit: I can not find the proper calibration guide, maybe anyone has one?


your firmware ought to be set to 600 steps for the extruder motor to move the filament 1mm into the extruder, this is the standard. For several reasons the number of steps needed might be higher or lower. To verify this let the printer extrude a certain length of filament, for example 100mm.

To do so print a small object, for example your calibration cube, so that the printer is heated up and the extruder is filled. Then go to repetier, manual control tab. Let the extruder heat up to your preferred printing temp, usually 190 degrees and drive z up to 100 - 150 mm. Speed should be set to normal printing speed also, should be 30 mm/s by now. Then mark your filament about 130-150mm above the intruder inlet. measure the exact value and not it. For the black filament I use a piece of colored tape to mark. Now in repetier again let 100mm(or for the first try 50mm, if you want to save filament) extrude.
After extrusion is finished, again measure the distance between extruder and your mark on the filament.
Calculate the difference between your first and your second measurement.
If everything would harmonize 100% then this difference should be 100mm (or 50 if you did so). Probably the difference will not be exact. Let’s assume your first reading was 150mm, your second 55. This would mean only 95 mm were extruded.
You calculate your need steps/mm: 600 / 95 * 100 = 631.6 = 632
So you have to alter the 600 value in your firmware to 632.
Depending on your actual firmware configuration you can do this in repetier config/firmware EEPROM configuration or by changing the value in your firmware files (better do a backup before touching). You find in Configuration.h, the line is like

#define DEFAULT_AXIS_STEPS_PER_UNIT   {64.25,64.25,2560,600}  // default steps per unit for ultimaker

Alter the last value 600 to 632.
Then upload the firmware to your printer, following the description for this procedure in the manual.

You can repeat the whole procedure now, the result should be very close now.

Hope this helps



Ok, so I found this guide, did everything as said, used the default numbers from EEPROM for the axes (64.25 64.25 2560 and 600 for extruder). However, no matter what number I add after calculating it, it still extrudes me only 79.5 mm instead of 100. What could be wrong? Could PLA be stucking in the extruder or something?
Also, where can I find the configuration.h file?

OK, let’s check it out.
Did you first try to change the values in the EEPROM window of repetier? If this is possible then your Marlin firmware is V1. You should see all fields filled out with different numbers. In the area with the steps per mm you’ll find the four values for the four steppers. In the field labeled “E” you find the steps for the extruder, should be 600. You are willing to change this to

600 / 79.5 * 100 = 755 (this is much, how much preload did you give on the extruder spring).

So enter 755 and click “Save to EEPROM”. To be sure your value is stored properly, shut down repetier disconnect your printer from voltage and usb and then start it all over again. If you go to the EEPROM window of repetier now again, you should see 755 for the E steps now, not 600.

Second possibility: All values in the EEPROM window are always 0 when you open it. Then you perhaps have Marlin V2 already installed, which by default doesn’t let you change the EEPROM directly.

In this case you have to go the other way, changing the values in Configuration.h.
Please check out first the behaviour of the EEPROM config window of repetier.



Did you file those screws down yet.
If not the bearing will get jammed and not put enough pressure on the filament mean you will not get the correct flow.

Yes, I have cut down those screws already.
About the software, when I open the configuration (alt+E), I see zeroes everywhere. How can I open configuration.h file?

Have a look at the last chapter of your assembling manual. There is a step-by-step instruction, how to update the printer’s firmware yourself. At the point, when loading the firmware files in the arduino software there is a screenshot with the loaded files. In my version of the manual this screenshot is on page 612 with the “Marlin” tab active. The tab to the right is labeled “Configuration.h”, it is a bit difficult to read in the manual. Making this tab active (just click on it), you can comfortably make your changes here. Make a search for “600” and you will quickly find the line with the stepping values. Change your value.
If you want to, you can do another search for “chitchat” and find


Uncomment it to


This will allow you to change the EEPROM values in the repetier window in the future.

Now proceed until you succesfully have uploaded your firmware. If you have activated chitchat you be able to see the stepping in the EEPROM window of repetier now, with your own value for E stepping. Repeat the extruding procedure again, now more filament should be extruded.

What about Wrong Way’s question with the screws. Did you file them down? And what about the spring preload? With my printer I have to little extrusion if it is fully loose. After one full turn in nothing changes anymore, I usually have it two turns in. But this differs from printer to printer.

Good luck!



Hi Linas_capas,

Configuration.h is one of the settings files of the printer firmware, Marlin. So, when you want to alter the configuration through this file, you need to reload the firmware afterwards. The whole procedure is explained on the K8200 website.

In some cases (depending on which firmware you are using etc.), you will need to get the firmware to rewrite the EEPROM values afterwards, otherwise the old values stay in the EEPROM. This can be done in Repetier Host, EEPROM window, by pressing the button “Restore factory settings”.

When you do the E steps calibration, use small extrusion speeds only, comparable to those speeds that are present while printing. High speeds can cause a blockage in the hotend due to the increased internal pressure, so if you see (or hear) any signs of slippage between the filament and the transport screw, lower the speed. Usual extrusion speeds would be below 100 mm/min, I’d say even 60 or 50 mm/min, but you can simply estimate whether the extruder gears turn at the same rate as they do during printing.


EDIT: Got it perfectly fine, thanks everyone for helping me out. More questions to follow :smiley:

New questions:

  1. As said in the assembly manual, i set each stepper driver to 0.425 V. I have seen in the forum, some people say it is best to set 0.55 V. so which way should I set my drivers?
  2. After printing

Layer height
Objective: to correct the layer height settings to reflect your printer’s actual layer height.
Calibration Object: 0.5mm-thin-wall.stl

Everything appeared to be fine, nozzle not touching or draging through the layers, only this issue:
First layers appear empty, but after 2 or 3rd layer it gets smooth. Could it be nozzle to close to the heatbed or maybe extruder does not get enough filament? I add the video: …

  1. Then I tried to print a box to check infill, but when infilling, nozzle touches the infilled plastic when draging. Is it something wrong with layer height, or I need to adjust some kind of infill settings?

Objective: to correct the infill setting.
Calibration Object: 20mm-box.stl


  1. I would let the voltage down, if your printer is running smooth and you have not problems with layer-shifting or loosing steps. Why stressing your semiconductors while a drop of oil can do the job?

  2. Can’t see it clearly, but maybe the hot-end was not filled when starting the print. This happens after the previous print, then hot filament is dripping out of the nozzle.
    After starting the job and the bed temp has reached it’s setpoint watch the extruder temp raising. When it’s about 170C, turn the big extruder gear until a small amount of molten filament squeezes out of the nozzle. Then the print will start with a filled nozzle.
    You can also print more skirt or 2 or 3 mm of brim to achive this.

  3. Never had this problem, sorry no idea.



I have all of mine set to 0.55
Never had a problem.

Lubricate is a very good idea

Maybe if someone shared their configuration of the printer, I would not neet to calibrate that much? Or are each printer is much different from the other, so configuration would not be suitable?

Hi Linas,

forget it, there is no one-fits-all calibration for 3D printers, even within a single model like the K8200.

Many parameters depend on the filament you are using, and on the objects you are printing. Lots of practise is the only way to get an insight into what works and what doesn’t …