Z-Axis skipping and other strange stuff


I have a problem with the Z-axis, at some point it starts skipping, it never did that before, it is since this week…
it looks like there is not enough power available, sometimes it even starts to turn in the wrong direction so it goes up instead of down blokking the printhead. not sure if this this the driver, stepper motor or cable, the cable shows burnmarks on the the mainboard side, this happens since a few days even on smal prints of only 10 min.
due to this the buildtak got damaged and hopefully this did no harm to the printhead

other issue it that the printer has issues maintaining the heat in the printhead, i needed to lower the cooling fan to 30% in repetier host settings, otherwise it cools down to much clogging the printhead during print… this started to happen since a few months

sometimes the printer just resets itself like it lost power and restarts, killing the print to waste. Started like a month ago.

this makes the printer at this moment in time unreliable/unusable and i have no way of printing successfully parts that take longer than 20 to 30 min as something will fail, 2 prints in a row is almost not possible.

This all could be overheating drivers or maybe even the PSU that is failing…

how can we analyse this and make sure this gets resolved, i need this printer to print parts…

Peter Joris

With so many problems occurring at the same time, first thing I would do : check the voltage of the power supply.

As Raby said check the voltage of the power supply.
Also check the screws on the power supply and the control board make sure they are tight.
These vibrate a lot and the screw could have come loose.

Well, I finally got some time to check things out…

voltage on the power supply is 15.1 to 15.2. Should i really adjust it to exactly 15? i think this will not cause the issues i have…

print behavior is still the same, unusable, certainly on larger prints, i have the feeling all the stepper drivers are overheating or so… sometimes i have to much filament en next time not enough, i have to play with the flow-rate as when it goes in to much the filament is skipping (not the stepper, well i think) its the re-bounce of to much pressure in the tube.

next few minutes it can be the case it is not filled up, i already cleaned the printhead, the same result…

the burn marks on the z-axis cable connector seem to get worse too.

Any idea?

Check the voltages of all your stepper drivers, you can find more information here: k8xxx-3dprinters.crimed.be/w … er_drivers

checked them

Voltages on the drivers:

z-axis: 0.922
X-axis: 0.922
Y-axis: 0.924
E : 0.925

That should normally still be okay, I tried to get mine at 0.9 but 0.925 is normally not to much so it could overheat…
If they do overheat however you should adjust them.

been thinking about that…

if i lower the voltage what is the effect on the driver and on the stepper?
if from my Z-axis the cable already has burn marks now, if i lower the voltage, the Amperage goes up… increasing the heat in the cable even further.
now, it is the first time i measured it… and they all seem to be very consistent in voltage…

the is E is very inconsistent but i think (and am almost sure) because of the Z-axis running a few times against the print bed, the print nozzle is damaged and narrowed the 0.35mm to something smaller… i have to run at 210-215 degrees to have it print PLA, anyway lower than 205 is not working where i printed at 195 and less before the z-axis issues occurred.

Also i cannot get my head around why i have to run my cooler on 30% or so for the print head to maintain temperature

Don’t lower the voltage of the steppers. The motors will struggle to move and the drivers will heat more.

[quote=“peterjoris”]if from my Z-axis the cable already has burn marks now[/quote]It’s not normal. There’s not enough power sent through those wires to burn them. Are you sure your Z axis is moving freely? A bad bearing can increase the friction and the current in the motor.

well, with the power off of the steppers i can easily turn it by hand… takes hardly any effort to move up and down by hand.


can you please step in here… less then a year old. this thing should still fly…
also if my z-axis is flipping out and runs into my print nozzle, @#$%ˆ&*( happend again… why is the endstop not stopping the stepper motor… you would expect that this works and is there to protect it

on those moments could it be that the mainboard is going mad for some reason? or just is failing now?

i mounted a cooler fan directly on the driver to keep them cool, so they are not overheating they feel cool when the z-axis is driving it in to the nozzle…

Try cleaning the endstop with a q-tip and check all the wires.
My wire came loose once as well because of those crappy connectors, this made my nozzle crash my build platform.

The endstop is always working and everything is connected just fine… it’s just not working when de z-axis is doing strange things… in cannot even stop it when i reset the board with the reset button… i really have to take the power off to just make it stop… it looks at that moment that all connection from the controls and the steppers is lost

strange behavior indeed. From all the observation one seems to be very important to me: the Z axis doesn’t stop even when pushing the reset switch.

If the reset switch is properly connected, all I/O pins of the microcontroller shall be tied to a a power-up level (I have in mind that this is a login High level at the pins).

However, in this condition nothing should happen.

If there is still any movement, you have the following error mechanisms:

  1. reset is not connected to the micro-controller (if the Vellemann Logo appers after reset, it is most unlikely)
  2. the micro-controller is damaged, (at least the I/O pin for the control of the z-axis)
  3. the motor driver is defect.

Before you start to deal with a defect board please check the header board of the Z-Axis. Change the driver board of the Z-axis with one of the other axes.

If the failure appears at the changed driver, you need to replace (repair) the driver board. If not, then you should check or replace your mainboard.

You may reprogram the firmware to be sure that the observed behavior is not related to errors in the software. However, I suggest a problem with the driver board.

Hi, thanks for your answer,

the reset switch also always works, except in the case the z is failing…
normally at press it is nicely rebooting with the velleman logo at startup. when the z-axis is failing… no response at all, not a restart nothing… i really have to remove power from the printer to make it stop as it is trying to kill itself…

i had the idea of a failing driver as well, so i already swapped it… issue is the same, it works until a certain point when the printer decides to kill itself, sometimes 10 min sometimes 1 hour… there is no common sense into it…

it sure feels like the mainboard that is failing and for some reason starts to live a life on its own, is there something heating up on the mainboard or some component that is not stable anymore and does strange stuff…

anyway i am not an engineer, just a user who is thinking of sending the whole thing to velleman, claim my money back and go for another brand… it is even a shame that they do not even react to this issue… i think they are just waiting until the warranty on the printer is ended, so i have to pay to get it working… in that case my money will not go to velleman

I’m sure you have done this but I will throw it out there just in case.
If you updated the firmware did you use the Arduino software 1.0.6 or lower?

Yes i did,

i am actually thinking of going back to 1.1, as gradually i got more issues… i could be that this all started arround the time i upgraded to 1.4… also a bit afraid that it ruined the printer and that going back will be of no help at all

but if i find some time i sure will try…

Just a short follow-up:

after swapping the driver, did your problems still appear on the z-axis?

If it is like this, I would share your assumption that the main board has some problems. You may raise an issue for replacement part to Vellemann as described in this forum.

I can understand your frustration, If you are looking for a single head printer you have a increasing choice of brands at this time. If you are looking for a two head device (like me), there are only a few parts on the market, where the K8400 seems to me a good compromise between cost and performance.
However, as many of the other users I have encountered several problems, adopted the solutions already available in the community or made my own trials. I experienced, that the 3D printer technology is still in a rudimentary condition but with a strong learning curve due to the broad interest in these things. So you need not to be an engineer (although it would be helpful some times), but you should be handy with mechanical tooling and electronic basics. Because of this impression I believe you won’t have these problems with another brand, you will have others for sure.

an update from my side…

as i previously suspected a heat issue on the mainboard i mounted a fan that blowed directly on the mainboard and driver… in the hope it would keep ik cool unlike the misplaced fan in the bottom of the case…

i was happy for at least a few hours, did a print of over 2 hours and all went fine, then the next going from the 2nd to the 3rd layers the z-axis was making a strange noise… what happend i did not move the complete layer only a few steps i guess as the print was pushing fillament on all sides and the printhead was scraping over the previous layer and the e-drive fillament was skipping again…
so i stopped the print and the and used the auto home command from the menu X and Y went fine to the home position, z-axis started to move down… with and very loud noise. reset did not work not on the mainboard nor on the display… so had to swtich of power again to stop it from hitting the bottom…

after powering up… it tried the auto home again… Z went down instead of up waited half an hour, powered up and still the same Z goes down on auto home… and it seems i can stop it by pinching on the Z-axis rod and start it to turn in any direction that i turn it by hand!!! measured the voltage on the drivers all like before +/- 0.923v as it should be

i will try again with some time in between until it start to act normal again if ever…

So i can conclude that it is probably not even an overheating issue but something else on the mainboard or drivers that is messing up after some time… and it is not only messing up the Z-axis but also the E drive for the fillament… it start to push filament to fast making it skip in the tube…

i would love that someone from Velleman steps in to confirm the issue so i can order new parts to swap on the support site (well if they could also tell me what to swap, that would be nice)