Y motor not in use but still hot

Hello forum,
I’ve been going through all the threads here, but I haven’t found an answer.
The Y carriage moves freely. The belt is correctly tensioned. The home position is correct. I don’t move the axle just scroll through the menu and during this time the motor warms up. I have already restarted the whole printer several times but the situation is still the same. I even tried to connect the Y motor to the X driver and the motor still heats up. The X motor on the Y driver is cold.
Is warming up the Y motor without using it normal?
Thank you for your help.
Milos

Translated with www.DeepL.com/Translator (free version)

hello @milos_pavlat

Check the Driver board For Y is these are correct mounted on Main controller board.
This has one orientation! See instruction manual. If this was wrong placed wrong orientation this driver will be immediately defective.

Check also for false contacts.

I think the stepper driver PCB is defective (the Y Motor driver).

Replacment boards: Stepper driver board - Whadda

Best regards,
Velleman Support

Hi!
@VEL450 (Support Team): The Nano have no seperate Driver Boards. The stepper drivers are direct soldered on the PCB. Check your mounting instructions. :wink:

@milos_pavlat:
First step… Maybe the stepper motor cables are not correct connected to the plugs. Please check that all cables on the plugs have the same order. At my printer it is:

  • at the plugs to the Mainboard: Blue, Red, Green, Black.
  • at the plugs to the stepper motors: Red, Black, Blue, Green.

Greetings

1 Like

Hi Steffen,
I checked the cable colors and they are the same as on your printer. The colors of the other motors match. Also the cable routing seems to be fine.
Otherwise the Y motor works correctly during home position or offset settings.

Unfortunately I still haven’t printed anything because I have a filament problem, but I guess I’ll have to start a new thread for that later. I don’t have time today.

Greetings from Prague
Milos


Hi @milos_pavlat

If everything is correct wired up, stepper motors connectors are plugged onto the correct motor connector mainboard. and the motor heats up, that’s not normal.

Maybe defect stepper motor, or stepper drivers on mainboard defective.

I think it’s best to send ik back to local shop for RMA request.

Or if you think there’s a problem with mainboard / stepper motor, You can open a new Ticket on our customer service platform, so we can help you further.

@Steffen-Berlin indeed, my excuse, Apparently I over looked it was vertex nano.

Best regards,
Velleman Support