Y Motor Control Problem

Hi all,

Recently had been having the problem of a staggered or jumping print in the Y axis, after 10-15mm height in print, the y axis would jump or skip printing the next layer with differnt Y coordinates. I did a bit of forum trawling and there we’re a few suggestions on how to fix this, these included,

  • Lubricating rails
    -Updating firmware to V2,
  • Increasing motor voltage to 0.55v,
  • ensuring belt is not too tight

All of which I did, and when I try my printer again I find the Y motor no longer moves, it locks solid (I cannot move the bed by hand at all) and makes the high pitched whine of a motor under strain when it is controlled from Repetier in manual. This is where this gets a bit more confusing and seems to be different from most of the other posts on this topic.

I have switched the Y and X motor connectors, in this case the Y axis moves under control of the X manual controls on Repetier, showing it is not a problem with the motor or its wiring, and that the bed moves easily and freely.
I have then thought it is the motor drive board (the small one on which the voltage is adjusted), so I switch the X and Y drive boards around (with all the cables in their correct original connectors) expecting to find the problem now moves to the X axis and the problem is the drive board. However the problem remains on the Y axis under the control of the X drive board. I have also tried changing the voltage back to the 0.425 it was at before.

I have now ran out of solutions to try and am still nto sure if I have solved my original problem in the Y axis. At least getting it moving again would be a start.

All ideas and help would be appreciated. Thanks

Strange problem.
If it is not related to the wiring, the motor or the driverboard, then we must suspect the main board.
If desired, you can return the board for inspection/repair.
Please return it to your distributor or direct to Velleman.

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere

Please include a detailed fault description.

US residents: please call (817) 284 77 85 for RMA#

Thanks for getting back to me so quickly. I was just about to send the board back when I thought i should try going back to the V1 of the firmware to check that wouldn’t be the issue (I had upgraded to “Firmware_k8200_marlinV2” as it was a recommended action to get rid of the unwanted shifts in the Y direction which was my original problem that other users had encountered, due to it getting rid of the checking for endstops at certain points), and having just uploaded the V1 from the downloads page the printer is moving fine in all axis. Am going to check and see if the shifts are still occurring tonight and will post the results.

Just wanted to check if V2 is compatible with all versions or is it exclusively for the versions which have been modified to include the SD card and LCD display? Mine does not have this modification but I assumed it would work anyway, or is there other parts of the system i must upgrade to use this firmware?

Thanks again,

Firmware V2 is compatible with all versions.
You only need it if you use the standalone controller or if you have false endstop trigger issues.

Hi again,

So as I said previous I reverted back to the V1 of the firmware, again tried to print my part and again I have encountered failed prints. The motors are still set to 0.55v, the bed moves freely etc, etc. The original problem (seemingly of false endstop signals, at a certain layer in the print the y axis will shift by up to 12mm or so and continue to shift randomly as further layers are printed, if this isn’t the issue I’d love to know what is?) seems to have returned, which the solution still seems to be to upgrade to V2 of the firmware. I have again uploaded V2 of the firmware and the problem of the Y axis not moving has again returned. Surely if version 1 of the firmware allows the Y axis to move the board must be functioning correctly? the problem with my Y axis locking solid when it is attempted to move seems to be caused by the V2 firmware. Am now completely stuck and would really appreciate some help here…


Very strange.
The only difference between firmware V1 and V2 is the end-stop handling.
There are no known issues with V2.
Please make sure there is no wiring issue.

I have a new kit I purchased 10 days ago and I was about to post a report of a very similar problem with the Y axis.
In my case the stepper will not move beyond an initial 1 mm. jerk (pulse). The mechanical aspects of the printer are all good. Rails, End switches etc.

I am running;

  1. the Certified Host Version of Repetier V0.95
  2. The Marlin Version 2 software downloaded directly via this site.

I too have done the following:
A) Exchanged the A4988 controller boards with the X axis, problem remains on the Y Axis
- Concluded A4988 is ok … ? (am I wrong?)
B) Switched the motor leads X for Y, problem moves to the X axis
- Concluded Wiring is ok … ? (am I wrong?)

Called Velleman USA tech support, conclusion was it is a defective control board. BUT and there is a big BUT. … While testing I in advertently jerked the USB cable, resulting in the removal of the surface mount USB connector. I repaired the issue by soldering the leads of a USB cable to the board as indicated on this site. The results were good and the board responds properly. Unfortunately this voids the warranty.

So since I am on my own in this quagmire, I looked further .

I downloaded all the spec. sheets I could find and took out my meters

At the A4988 socket for the Y-Axis
GND are all good
+Vin (VMOT) = 15v
MS1, MS2, MS3 = 4.9v
+5v = 4.9v

I measured the windings on the Stepper at the connector and get 1.9 ohm and 1.8 ohm on each of the windings, so these are just slightly higher than spec (probably the wiring) and I assume are good.

On the advice of Velleman USA the A4988 board has been set to 0.550 v

Using a magnified I looked for any problems with the tracings and found none.

[size=150]So, I am at a complete loss. Is there anyway to repair this / get it working?[/size]

I also have another problem that may or may not be related.
Repetier Reports the Bed Temperature as 52 degrees C, this is incorrect.
A) Measured the thermistor at the board connector and it reported 110k ohms
B) Used multiple resistors 20k ohm and up to a full open as replacements for the thermistor
In all of these cases Repetier reported the same Bed temperature.
- Conclusion, there is a problem in either Repetier or the board
- Observation, It appears the value may be a stored value from some where. Originally it was stuck at 40 degrees C. I upped the target temp of the Bed to 70 degrees C, the system worked properly and took the board to 60 something degrees, but after that the value was stuck at 52 degrees C.

  • Hypothesis, there is a problem with software or the hardware interface.
    I stopped looking into this because of the problem above …

Thanks in advance.

The USB-issue will not void the warranty of the rest of the board.
We’d suggest to send it in for inspection/repair. You will be charged if you would like to have the USB connector repaired of course.


I have the same problem.

Original Merlin: everything works fine
Merlin for LCD: Y axis doesn’t move or actually skips 0.5 mm and holds the motor.

Does somebody have a solution for this? I really would like to use my LCD panel.

I had similar issues with X axis and later the Y axis. Possioning erratic or no movement. In both casses it was a broken wire to the stop switches ( wire very fragil),

Found somewhere on the forum that the stop switches are normally closed and open when depressed.

Yes the K8200 has a lot of small issues to fix ( some my own doing) but once done it is well worth the $500 I paid for the kit.

I also have the same problem. The Y-motor doesn’t work after firmware-upgrade to use the standalone controller.
Before it was working fine, all over sudden a broken wire? I don’t believe it!!

a moment ago I downgraded the firmware to Marlin 1 and disconnected the standalone controller.
The homepoint is perfect, the Y-motor, X-motor and Z-motor do work perfectly.
The soldering of the connector for the standalone controller on the board is checked, is perfect.
So: leaves only the software to be corrupted, or missing I something here???

Did you try to upload the V2 firmware with Arduino 1.0.6 as newer versions are causing some trouble.

that did the trick!
Unstalled the newest version of Arduino.
Downloaded and installed version 1.0.6
Downloaded Marlin V2
Opened it in Arduino
Selected the right board and comport
Upload and flash and now it is printing like it always did!

You’re welcome:)

Happy printing!


I just build my printer and now i am testing to see if everything works…

Most of it works the only problem i have is that -y don’t work when i try to manual control the motors but the +y work…

I tried to change the y axis with the x axis and then the -y axis worked… but then the -x didnt…

So i am sure it is not a wire problem but the controler board there might be broke…

Or do you thing there might be some other problem

From what you have said it sounds like the end stop for the Y axis is open.