Y axis studder, suspect board issue


I bought the K8200 and set everything up as per the manual. The system boots, makes the G-code with images from Thingverse, comes to temperature, and (mostly) moves. The only issue we really have is the movement itself. Specifically, the y-axis has an issue with motion.

If you go through the motions, around the center of the motion, it pauses. The computer seems to keep track of how many millimeters it was sent, but does not keep track of how far it should go. You can hear the stepper motors, but the motors won’t move as far as they think.

First, I double checked all of the wires. Everything seemed to be assembled properly.

Next, I tried going through and making sure the X and Y wires weren’t the issue, by switching the X and Y wires for both the motors and the limit switches. When I did this, the issue switched to being in the X direction, suggesting that the issue was not with the software on the computer or a mechanical defect of the stepper motors or bad limit switches.

I thought it might be a bad driver board or poor voltage control, so I switched the X and Y driver boards, but nothing changed.

I tried switching the USB cable just in case, but there was no issue.

I tried moving the power supply further away from the rest of the circuit, just in case there was some signal radiating away from it and had no luck.

I was left with suspecting a bad circuit board- either in hardware or firmware. I can’t think of a good way to test this with the materials that I have. Does anyone have any suggestions on what else it could be? Could I get another circuit board so I don’t have to return the whole piece in it’s entirity?

I appreciate any help you can offer. Cheers!

Make sure your axes move freely and check if the stepper drivers are set to 0.55v.
Also check if your pulelys are tight and the belts not overtightened.

Those all check out. Any other ideas before I return it, then?