X and Y movement, falsely activated end stop

My x- driver board was replaced after I had some trouble with changing voltages. First by me, (buying a new one) but also by Velleman.
After mounting mine, the printer worked, but seemed to be having trouble with the X-auto home. This resulted in my prints being made somewhat left of the center of the platform.

With the new driver board, the x axis end stop seems to activate directly, the moment I power up the machine.


  • Both manual directions of Y movement result in a movement foreward (!!)
  • X s only possible away from the endstop (even though it is appr. 100 mm away from the endstop

Autohome results in a movement forward (quickly reset by me). X thinks it’s already there anyway, so no movement in that direction during auto home.

I did check the wiring, bot connectors are in of the X an Y end stops.
I cleaned both end stops with a Q-tip.

I tried reloading the firmware… but it doesn’t seem to help. Does anybody understand what is going on? Tnx

23:09:31.543 : Reporting endstop status
23:09:31.543 : x_max: TRIGGERED
23:09:31.543 : y_max: open
23:09:31.543 : z_min: open

did you try re-seating the cable on both ends?

Thanks, That means disconnect and plug in again? Yes… I just did that.
Unfortunately that does not seem to help.

I now switched the X and Y endstops…to see if the mainboard or the endstop contains the problem.

The X of the mainboard is capable of reporting a non triggered endstop (Y plugged in there)

11:09:40.448 : Reporting endstop status
11:09:40.448 : x_max: open - That’s good!
11:09:40.448 : y_max: TRIGGERED (because I cant get the X-endstop cable to reach there)
11:09:40.464 : z_min: open

I can also see the X-stop is reported as triggered if i plug it in the Z-channel. That I can reach.
–> So I am focussing on the X end stop now… It probably is somehow disconnected or failing.

If you keep same cables on the endstops and change their places on motherboard you will be able to reach

Thanks Kulla, I managed to plug the X in the Z at the mainboard side… And see it is reported as triggered.
Now I guess I need to find out if either the cable or the sensor of the X stop is faulty I suppose…

(And I still wonder why the Y always travels forward, no matter what way I spin the wheel. :slight_smile: Ok ! one thing at the time…)

Hmmmm I disassembled the sensor cap and found OIL in it. It probably dripped in from the rod above.
(This means I did not properly clean the sensor before , you really need to take the hood off I guess…)

Yes! a step further:

11:43:28.402 : Reporting endstop status
11:43:28.402 : x_max: open
11:43:28.402 : y_max: open
11:43:28.402 : z_min: open
11:43:28.402 : ok

Y-behaviour is still inversed… always forward to the front of the machine.
I now found out this behaviour is connected to the new DRV8825 driver board for the stepper I bought. It is a DRV just as well, but looks different.
If I switch it to the X position, that axis will always move in one direction also, no matter which way I turn the wheel.

long story short:
I will replace the DRV8825 driver board, as I suspect it is broken. Tnx all.

I’ve had the same problem, cleaning oil of the sensor (removing the sensor cover) helped. The problem with Y-axis started after oiling the rods… Y-sensor seems to be susceptible to contamination as the placement of it is under the Y-movement rod.