X and y axis problems

Hi, my printer has suddenly stopped moving the x axis it makes a noise as if it’s trying to move it but it’s just “dead” and you can’t move it even by hand, also the y axis moves in manual mode but whether I send it to the plus end or the minus end of movement it only moves to the plus end…even when I try to get it to the home position…haven’t a clue what’s going on ???

That sounds like loose wiring. Make sure your motors are connected securely, and check any solder joints in the wiring harness.

You should already have adjusted the stepper motor control voltage on each driver board to about 0.55v, but it might be a good idea to carefully double-check this setting.

hi, checked all the wiring, swapped the motor controllers…no joy so it’s not those, swapped the motors…now the fault has moved to y axis and x axis moves but only one direction…regardless of which way I send it…only travels out away from home…but if I select home it does come back to the home position…z axis is fine and extrudes ok…all heaters work fine it’s only x and y axis, I also tried reinstalling the firmware…still the same

Check the wires on the end stop make sure none of them are broke.
Did you upload any firmware?
If so you need to use the Arduino software version 1.0.6 or lower.
The higher versions do not work with the K8200

checked absolutely everything, all wiring , no problems uploading firmware, swapped motor drivers the fault stays in the same place, I even tried it on another laptop just in case it was that, the only thing left is the controller board has developed a fault

What arduino version did you use whne reflashing the firmware?

Any version above 1.0.6 will lead to non working firmware and strange bahavior.

Hi, I’m using version 1.7.8, is that what’s causing my problems, if so how do I get hold of an older version

You can find all the previous releases here:


Choose 1.0.6 as version


Thank You VERY much Dylan, that worked a treat !!

You’re welcome!
Happy printing :slight_smile: