Wrong reading on therm1

So I have an issue where my nozzle thermistor reads around 120°C. Heating the nozzle works and reports back a temperature change. I tried to check the voltage on therm1 (nozzle) and therm2 (heated bed). Therm2 reads 5 volts and therm 1 reads 2 volts. I guess this is not correct as it should be 5 volts on both?

So what are my options here? How do I proceed and solve this issue?

Steps I’ve taken are:

  1. Flash a new firmware.
  2. Check the wiring.
  3. PID autotune

Hello weactivist,

Best way to check the thermistors, is to do it powered off and in cold condition (room temperature). Because the THERM1 and THERM2 are NTC resistors.

Put your multimeter on 200 kΩ and measure the leads of the NTC (or terminal THERM1 and THERM2). You should measure something between 70 to 100 KΩ depending how hot the NTC is. If your measurement is way lower than, it’s possible that the NTC is shorting out. Detach it, check it and attach it again.

Check also if the NTC is centered in the heater block. If outside the heater block, or half in & half outside, You’ll get wrong temperature readings “measuring” back. Check also the wires of NTC (fault contacts).

Best regards,
Velleman Support

Thanks for the reply! I’ve checked the thermistors and they are just fine. I’ve even replaced the nozzle thermistor with the same result. The voltage I wrote about above is for the Therm1 and Therm2 pins on the board. I think this has something to do with the board itself.