WM140 USB Interface Baords and USB 3.0 host controllers

I have upgraded the machine we use to communicate with our WM140 USB interface boards. (It runs Windows 10.) No problems installing drivers, and the boards correctly show in Device Manager. However, neither the Demo Programme, nor our own software can communicate with the WM140 boards. I notice that the web-site description of the WM140 specify “USB 1.1 or USB 2.0” but our Windows machine has USB 3 ports only. Obviously, the WM 140 does not have USB 3 Capability but surely, that should just cause the ports on my machine to revert to USB 2.0 operation which should then work fine at USB 2 speeds. What please is the reason for stating that the WM140s will only work with USB 1.1 and 2.0 ports (given that the USB 3 host port is backwards compatible) and how do I fix my problem so that I can communicate with the boards via a USB 3 port please?


Hello @john_fowler_son,

You can tray the latest driver for WM140 = K8061. You can download it from here: https://www.velleman.eu/downloads/files/downloads/k8061_driver_v4_0.zip

For installation follow this topic thread:

Info, manuals, Software demo drivers:

Best Regards:
Velleman Support

Thank you for your response. However, perhaps you have misunderstood my problem, I already have that driver fully installed and the three Wm140 boards which are installed in our system correctly show in Device Manager - therefore the drivers are functioning correctly.

The problem is that both our own software (which has always worked correctly over USB 2 on WIndows 7) and the Supplied Demo Programme will not connect to the boards over USB3.

My very specific question is this:- Why does the WM not work over USB3 even when the drivers are correctly installed and what can I do about it?

The WM140 manual says that they only work over USB 1.1/2 - yet the USB3 standard is fully backward compatible - so where is the issue please?



Normally the cards VM140 (WMI140) should work with USB3.0 and Win 11.

A workaround that can solve the problem is the use of an USB2.0 hub.
Make sure: USB cable lenght less or eaqual to 0,5m.

Can you let us now if this works?

Best Regards,
Velleman Support

Thank you for your response again. Just to correct one small point - we are running Windows 10, not Windows 11. However, our cable is more like 8m in length rather than 0.5!!! Our set-up has been in place for more than 10 years running on Win 7 via USB without problems, and comprises a cable with a repeater at mid length, running to a 4-way plitted which then leads to three VM140. This has worked very well but we are trying to update the laptop to run Windows 10 and now the laptop cannot “see” the cards. We can try temprarily moving the laptop closer to the interface, but I stress that the present setup work perfectly before - the only thing which has changed is that the new laptop has USB 3 sockets.

Best Wishes,