Where to buy replecment/spare parts (K8400)

My Printer has partly stopped working.
It’s the menu selector (Rotary Knob) that is failing. I can press it so that the menu appears but rotating the knob does nothing.
It is part of SUBKIT 21, LCD Screen and SD Card reader. I have no idea if it’s only the rotary encoder, or if it’s the backplane “VM8401’TW”. I have tried with my local supplier here in Sweden (kjell.com) , but they do not carry any spare parts beyond buildtak, nozzles and so on.

I have sent an email to sales@velleman.eu describing my problem, but so far I have no response.
Found that address on the page for spare parts (there I could not find any for my printer) here -> https://www.velleman.eu/products/spareparts/

So, Is anybody able to help me out here?

1 Like


Do you have a local velleman dealer nearby please check here => https://www.velleman.eu/shops/
There you can ask them to order your spareparts.

Best Regards,


Thanks for the answer.

I have mailed kjell.com, and asked for assistance.

In the mean time I would like to try to change just the rotary knob by desoldering the old one and replace it with a new one.

I did found the schematics on https://manuals.velleman.eu/article.php?id=223 and can see that the rotary encoder is a EC11. The problem is that there are plenty of encoders that is named EC11. Could this one be a valid replacement -> https://www.elfa.se/en/encoder-30-15-mm-form-alps-ec11b152420q/p/13584661?queryFromSuggest=true&no-cache=true ? It looks like the one on my printer.

Best regards,


Yes that looks like that one.
Here’s the exact version.


I’ll try the one I linked. It can’t get any worse in any case :slight_smile:

Before you replace it and since you can solder you should look at the solder joints on the back of the SD board. one of the legs may have come loose or broke the solder joint.
Just a suggestion.

Thanks for the suggestion, but the legs was a tight fit. I removed the encoder yesterday, after work.
It’s a double sided board, with some solder joints hidden beneath the rotary encoder.
It was really hard to get the encoder off. Did managed to lift off one copper ring from under the encoder, but it seems like it’s not connected to anything. I’ll take the safe route today and solder in the new one with wires, just to try it out.

Edit: Exact same problem with a new encoder. I’ll have to wait for kjell.com to come back to me.
(and I measured the cable from teh mainboard to the lcd-screen, and every cable in it worked),

hello svdv,hello sdvd, I looked at the okaphone website to buy pulleys but they only sell pulleys with a single threaded hole and not two like the news. maybe velleman has an idea of the problem. I do not understand why, moreover, at the selling price which seems excessive, I am a little shocked !!!

So I changed to GT2 20 pulleys and belts. Since I did (end 2016) never had a problem anymore…
With the help from: https://www.thingiverse.com/thing:2122512

Just got a call from kjell.com.
They had the spare part home, and are as we speak, ready to send it to me :slight_smile:
Now I am eager to see that it was the right part, when it arrives in the mail.
At least now I have a way in the future.

The spare did not fix my problem.
It’s the same problem as before. Now am I suspecting the cable. I did measured it, but at a closer examination,some of the contacts are a bit on the lose side.
I’ll try to get hold of a cable, or make one myself.

The problem with the menu is as it was. I can press the knob, and the LCD shows the menu, but if I try to rotate the knob, nothing happens.

So far I have replaced the backplane för the LCD-dispaly, there the rotary knob is attached, and I have made myself a new cable, and tried. Nothing works.

So the problem is as it was before, and I am running out of ideas.
If anyone has a bright idea, I am willing to listen.


Have you tried reprogramming the Printer?
Try uploading the latest firmware.

I have not tried that. Can try it out later today. Thanks for the suggestion.

Edit: If I load up new firmware, and the menu still does not work, then I cant use “RELOAD EEPROM SETTINGS”, and then my printer truly is useless. I have to think about it, before I do that step.