What is wrong with my Z-axis ? (solved+pictures of results)

Hello all,

I recently got this K8200 for my upcomming birthday in april. (Lol, my wife was thinking I would need weeks and weeks to build it, because the complete building PDF is about 760 pages)
So, I was a bit frustrated after my first print.
I printed a test-cube of 25 x 25 x 25 mm.
X and Y where off by a 10th of a millimeter. (so far, so good),
but the height of the cube, was only about 21 millimeters, instead of 25 millimeters !

I didn’t make any modifications to the machine (yet), only standard assembly like described in the building manual.
I did put the voltage of the Z-axis stepper upto 0.55V, but this does not help.
However, when I try to run the motor up and down for 10 mm, I perfectly get 8 exact rotations …
One thing I noticed, is when I use the “park” feature within Repetier, the X- and Y-axis can’t be moved by hand, but the Z-axis screw can be turned by hand !
Also, when printing, just before the Z-axis goes up, I notice a “click” in the motor.
It seems like the motor does not get any power to hold its torque, but only gets power when it needs to move …

When “switching” 2 motors, the problems stays with the Z-axis connection, not with the motor.
May I assume that my Z-axis driver on the controllerboard is DOA ?
Should I contact Velleman to replace my Z-axis driver ?

I can count myself as “somewhat” experienced, so “more complex” tests, to solve my problem, are welcome.
Also posting pictures or movies, to “make some things clear” is no problem :slight_smile:
(I already have an Elektor Colinbus Profiler CNC, a 50W CO2 laser CNC, and an HBM BF-25 milling machine, that I converted myself to CNC, however this K8200 is my first 3D printer)

best regards,

Its normal that the Z motor isnt powered unless its actually moving. And the clicking, isnt that just the microswitch?
IM guessing your problem is just with the slicer software/configuration.

Hi P4Man,

Thank you for your answer.
The clicking is surely not the microswitch, I even hear the clicking when I’m a few millimeters above the microswitch :slight_smile:
(and even when the Z-axis is almost 20 mm high etc … I can hear it always)

Is there a reason why the X and Y axis keep getting powered to hold torque, and the Z-axis not ?

What do you suggest to print a calibration cube ?
Do you perhapse have some G-code, bypassing the possibility of a slicer configuration issue ?

best regards,


It’s quite curious to have a too small height to your cube when your 10mm test is perfectly normal (the pitch of the threaded rod is 1.25 mm so 8x1.25=10mm).

Did you test with another object?

And it’s normal that the Z motor isn’t powered (you can turn it by hand which can prove useful to adjust the first layer).

I never heard any click when actuating the motor.

Could you post a picture of your test cube?


The clicking comes from the Z-motor itself. It seems like it gets “powered”, just before the last piece of a layer is printed,
and then the motor is moved up.
While laying in my bed tonight, I was thinking. It can’t be a slicer issue.
I use 0.3 mm layers, (which do look a little better then 0.2 mm layers !)
For the 25 mm cube, I get 84 layers, and for a 30 mm cube, I get 100 layers. (but they both end up beeing to small in height)
Last night I also printed a raspberry Pi case. The top of the case is 45 layers, which should have resulted in a 13,5 cm high object.
The printout was only 12,7 cm high !

I uploaded 2 highres pictures of the 25 mm testcube. (watch out for the links, they are 4 MB each !)
(I didn’t want to “embed” them in my posting for this, so I made links of them)


Best regards,

How about a very simple test; home your z axis, then in repetier move the extruder up by 100 or more mm using the manual controls. Try to measure the actual height as best as you can. Also, what version of repetier and slic3r are you using?

Hi sn00zerman,

the manual command may use a different speed than the Z movement during the print, so it could be that the test does not show an error that occurs in the prints. You can test this as follows: Slice any object you like, and take a look at the generated G-code. You’ll find a line like “G1 Z0.300 F9600.000” or similar (the numbers may be different) at the beginning of the first layer; this is the first Z movement. Copy that line into some text editor or write it down.
In the G-code editor window, open a new, empty text and paste the following lines:

G21 ; set units to millimeters G28 ; home all axes G90 ; use absolute coordinates G4 P500 In line 5, add your copied G1 command.
Copy and paste lines 4 and 5 a couple of times, and change the Z value each time by the amount of a layer height or a similar value, e.g.

G4 P500 G1 Z0.600 F9600.000 G4 P500 G1 Z0.900 F9600.000 G4 P500 G1 Z1.200 F9600.000 and so on, until you reach Z10.000 or whatever height you feel is a good choice. Between each Z movement and the next there should be a G4 command (a pause, in this case half a second), in order to get the firmware to stop the motor and create a movement similar to a real print job.
Connect to your printer and run this program, then check the height for errors.


Hi all,

I did some testing with G-codes, and the speed doesn’t influence the accuracy.
I tried with small steps (0.1 mm), and I notice I loose steps this way.
So, at the same speed, sending a command for 10 mm is OK, but if I send 10x 0,1 mm, I don’t get 1 mm up or down !

I checked everything, and noticed that the piece between the Z-axle itself, and the Z-motor, is “bogus” !
Just letting this piece sit on the motor, and turn the motor, I notice that the hole where the Z-axis fits in, doesn’t make a nice round movement,
but is out off center !
I just made a new piece on my lathe (I didn’t have such a small piece of aluminium, so I used brass)
Furthermore, investigating this “connection”, I also noticed that actually locking the Z-axis with a hexagon bolt, is not the way to go !
Using this method, forces the Z-axis to “interlock” with this connection piece under an angle (this is a small angle, but large enough to cause “wobble” on the Z-axis !)
While making my new connection piece, I decided to “lock” the actual Z-axis in the same way as the shaft of the motor …

Eeh voila, instant result ! No more wobling in the Z-axis, and a “correct” calibration cube. (I even measured 25.1 mm height in stead of 25 mm, but this is caused by the first print layer I assume)
I just started printing with another type of PLA (white, from Flyde in the UK), I had to put the temperature up from 190°C to 200°C and the multiplier to 1.25 :slight_smile:
(still need some finetuning on this, but 1.15 is to low for this type of filament, while 1.15 was to much for the black Velleman PLA, I used 1.05)

I will post some pictures tomorrow of the new connection piece, and the “old” and “new” calibration cubes next to each other :slight_smile:
(and maybe also some other printed things, depending how this evening will go by)

Ooh well, if this is the only problem that I got with this machine, I find myself very lucky. (compared to some horror stories I read on this forum)

Thanks for all who tried to help me :slight_smile:

best regards,
Where fun meets technology …

Many use the coupling with some kind of spring in between to solve this (not all of us have the machinery to make our own :wink: ) and it is also ok to remove the top nut and bearing bracket and leave it swinging around for a little.
There are some horror stories indeed but I have to say that my printer was all right when it was still original and with replacing parts it just became better. No real problems at all.


So, after changing the coupler between the Z-axis and Z-motor, and printing a new Z-motor support,
my printer seems to function fine :slight_smile:

I already printed 2 vases for my wife.
(note, the triangles in the sidings in the large vase, are also present in the drawings of this vase, so I can safely assume my printer is correctly configured)

Furthermore, I already printed some toolboxes, a waste bin, an alternative housing for the electronics, a LED ring, a fan mount+protection grill+nozzle, a filament guide.
This is how my machine looks like today:

for more detailled pictures (highres), you can always visit my blog at http://www.digitalplayground.be

I still plan to:

  • put a glass plate (21,5 cm x 21,5 cm - 3 mm thick) on the printbed
  • replace the Z-axis with a TR8x1.5D
  • change the teflon piece in the extruder with a very short teflon piece (as an isolator piece) and replace the rest of the teflon with an aluminium part, cooled by 25mm fans.

best regards,