Weird motor/driver issues

So I have a weird problem… my Y and Z-Axis aren’t moving. Everytime I perform an autohome command, the X-Axis acts normally, while the Y-Axis only goes in one direction. When i’m controlling it manually, it doesn’t even go in one direction. The Z-Axis doesn’t move at all, not when i’m homing it, nor when i control it manually. I’ve checked all the stepper drivers, they all run at about 0.9v (How it’s supposed to be). My question now is, what’s the issue (Motors, Drivers, etc.), and how can i fix it?
Thank You

Axis moving only in one direction usually means end-stop issue. So check the end-stops, their connections (check that you didn’t plug them wrongly or switched two of them). If you oiled the rods, clean the end-stops as some oil droplets can end up there and block the IR beam.

This can also mean the driver for that axis is failing as well

Thanks to both of you, it was partially the drivers that caused the issue, but the endstop was a problem too! But now I cleaned it, it worked for a few days, but now it doesn’t work again! I tried cleaning it, but this time, it doesn’t seem like that’s the problem… any suggestions?