VMA405 with Raspberry Pi 3 B?

I purchased a VMA405 for arduino, intending on using it for RFID with my Raspberry Pi. I followed a tutorial here to install the necessary Python libraries for the RC522 chip, but I ran in to a problem with my code:

#!/usr/bin/env python

import RPi.GPIO as GPIO
import SimpleMFRC522


reader = SimpleMFRC522.SimpleMFRC522()

text = raw_input(‘New data:’)
print(“Now place your tag to write”)

The error trace I get is

Traceback (most recent call last):
File “Write.py”, line 8, in
reader = SimpleMFRC522.SimpleMFRC522()
File “/home/pi/MFRC522-python/SimpleMFRC522.py”, line 14, in init
self.READER = MFRC522.MFRC522()
File “/home/pi/MFRC522-python/MFRC522.py”, line 117, in init
File “/home/pi/MFRC522-python/MFRC522.py”, line 390, in MFRC522_Init
File “/home/pi/MFRC522-python/MFRC522.py”, line 120, in MFRC522_Reset
self.Write_MFRC522(self.CommandReg, self.PCD_RESETPHASE)
File “/home/pi/MFRC522-python/MFRC522.py”, line 123, in Write_MFRC522
TypeError: function takes exactly 2 arguments (1 given)

Is this a problem with the compatibility between the VMA405 and the Raspberry Pi, or am I just doing something wrong?

Hi! I saw this post just today when I tried to connect my reader, my code looks similar, but let me just give you a few tips:

On this link you can find how to connect to an Arduino, look at that, then use the next link to see how the MFRC522 reader should be connected to a raspberry, compare the pins on the raspberry with the datasheet.

Try this, and if it doesent work, then just use the guide on link 2.

Best of luck,

Thanks for sharing. :+1: