VMA354 connecting to WiFi

I have a VMA354 that should connect my Arduino to the internet and use the Tuya app. I hooked it up to the arduino and loaded the test software provided on gifthub. That works so my arduino can communicate with the module. However I can find nowhere how to connect the module to the wifi.

This module uses serial communication via i2C, all the wifi and ethernet libraries for the arduino use SPI interface, so using them did not help me.

Someone a suggestion?

Hello Asolex,

Check the serial connection. Make sure that TX of Tuya board is connected to RX (PIN 2) of Arduino,
and RX of Tuya board is connected to TX (PIN3) of Arduino board.

NOTE:
Recommended RX,TX => use pin 2 and pin 3 of arduino!
Make sure it’s not connected to the TX,RX pin 1 and 2 of arduino!

See below the pin assignments for Arduino Mega as well.

 *  Connections:
 *  VMA354    Arduino UNO     Arduino MEGA
 *  VCC       5V              5V
 *  GND       GND             GND
 *  TX        RX (pin2)       RX1 (pin19)
 *  RX        TX (pin3)       TX1 (pin18)
 */


//libraries
#include "Tuyav.h"
#include "global.h"

//selection of Serial port
#if defined(ARDUINO_AVR_UNO)    //Arduino UNO board: use SoftwareSerial with pins you select, see https://www.arduino.cc/en/Reference/softwareSerial
SoftwareSerial mySWserial(2,3); //RX,TX (2 and 3 are recommended)

To set up the Wifi connection.

Use the TuyaSmart app.
For android devices: https://play.google.com/store/apps/details?id=com.tuya.smart&hl=nl
For apple devices: https://apps.apple.com/us/app/tuyasmart/id1034649547

Open the TuyaSmart app, and add a device.
Follow the wizard. Connect Your phone or tabled with Your Wireless router, and give in Your SSID and password. Now, push and hold the button on “Tuya board” (VMA354) for 5 seconds, till the RED LED flashes. Then confirm if the led blinks in the wizard. The app will now searching for Tuya boards (devices). If there’s found one, it will be added to Your Wifi network.

Best Regards,
Velleman Support

Hi, the connection between the board and arduino works, the demo program states the status of the digital and analog inputs.

Finally got the module to work, the wiring was wrong, assumed red was vcc and black gnd, but is not. Confusing.

Needed to use the AP pairing mode to get the connection working to the app, but now it works.

Alex

Hello,

Nice to hear, that it works now.

we wish you a lot of fun with this module

Best regards,
Velleman Support