VM205 for rpi - cannot run pascal file

New install Raspian and downloaded software then when compiling in Lazarus I get error vm205_1.pas(35,22) Fatal: Can’t find unit FileUtil used by VM205_1

This seems to be a problem in Lazarus / Free Pascal.

If you do not need to modify the operation of the software, there is no need to compile the source.
You can just use the executable file VM205 according to the user manual.

The file VM205 extracted from the download is a text file in the format of a Pascal source file. It is not executable. That is why I tried Lazarus. I can’t find any executable files in the downloaded zip folder. So not sure what to do now. Hope someone can help.

There should be an executable file VM205 (size 16599 KB, dated 19/5/2017) too in the zip folder.
It is included into this download package:
Software package for VM205 with Pascal source code (Rev1.3) available from Velleman VM205 downloads site.

Thank you for your assistance I now know exactly which file to use. I have now worked on this some more and find the VM205 file properties are only read and write so it is not initially executable on rpi. I have used chmod and changed the file properties to executable and it now loads and runs successfully. Many thanks for your help.

No problem. Glad to see your VM205 is OK now.