VM202N MP3 Jukebox problem

I recently purchased one of these modules. It plays fine, except none of the control functions appear to work. (Pushbuttons) The module starts playing on power up as expected, but the LED wired as shown in instructions is blinking while playing. (Should be On solid if I read the directions correctly) The resistors supplied were used in this initial power up with N.O. buttons. (Final application will replace the buttons with dry relay contacts but I wanted to keep initial tests simple) Pushing the buttons has no effect on operation; it plays to the end of the single MP3 file on the USB Flashdrive, then simply starts over. It is operating directly from a 5V source, filtered and regulated. Am I overlooking something, or does this sound like a problem with the module?

The final project consists of a mono program on one channel which is sent to a speaker. the other channel is sent to a tone decoder which closes the relay contacts for 2 seconds to put the module in its “pause” state. A second pulse will at an indeterminate time be sent to put it back in “Play” when the program is requested. the sequence repeats as needed until the end of the program (each operation only plays a portion of the total program. At the end of the file a second tone initiates a power cycle which resets the module, followed by a single pulse putting it in “pause”. The cycle then repeats. Any help appreciated !

Try removing the LED to see if that helps.

No go, tried that. I also disconnected everything and powered from a separate power source (5V filtered), no help. Also tried another memory source, the original was on a flash drive, the second try I used an SD card. Same results; music plays but no buttons function and LED blinks while the selection is playing.

If the LED is blinking that means you did not remove it.
Try it with just the resistors and the switches

I wasn’t clear on that; I did try it with the LED removed and the program just looped. Buttons did not work. Also tried adding a 1K resistor in series with the LED on the off-chance it may have been loading the module too much. No fix, except as expected the LED was dimmer.
Even tried using only the Play / Pause button since my application will not need FF / REV. No help. Have contacted my supplier; still waiting for disposition from them.

Just an update. i am not satisfied with this module It was replaced by the supplier; new one acts the same way. I tried it on the bench right out of the package. I used the 9V power adapter cord as supllied thinking possibly leaving the power regulator on might have something to do with it. Powered from a 9V battery so no issue with filtering from a power supply. I connected ONLY the switches, The module started up on power up playing the single MP3 from the flash drive. It played and looped as expected, but the buttons had no effect on operation.

Next I tried using an SD card instead of the flash drive, same thing. I tried 2 different flash drives thinking maybe there was a compatibility problem. same thing.

As a matter record, the Flash drives were a PNY 2 gig (older model) Also a PNY 2 Gig SD Card and a SanDik 4 Gig Cruzer. The MP3 was done on a Windows computer using Audacity as the MP3 recorded to edit the original from a cassette tape. The MP3 plays exactly as it should directly from the SD Card and flash drives so I am certain it is properly set up (The audio is on one channel; a control tone is placed on the other) Separation is good and the support circuitry responds properly to the control tones.

Just an FYI, I used a similar setup with the now obsolete VM202 a couple years ago and it performed exactly as I expected; button functions and tones good. Something differs between the 202 and the 202N versions…