VM111 - INHX8M hex file

Hi, I have just purchased a VM111 programmer/development board and have tried to program with a simple C program. When it came to programing I noticed that I was asked to open a INHX8M hex file.

The problem is my CCS compiler does not generate such a format, and the programmer informs me of this issue.

Do you have any suggestions to get around this issue?

what format of hex does your compiler give?

I don’t have any problems with INHX8M, INHX32M so I don’t think the problem is in the hex-file

Thanks for your comments however, when loading a file in the programmer you are prompted to ‘open INHX8M .HEX file’ so as your compiler or assembler is able to generate this format clearly this wouldn’t cause an issue for you.

My CCS compiler can only generate 8bit and 16bit .HEX files.
The programmer loads the demo file that came with the kit and this works fine it is only when I try to load a .HEX file that my compiler has generated (Which by the way works fine with another programmer) that the velleman programmer states 'WRONG FILE-FORMAT.

Any suggestions?

With the progPIC software (K8048/VM111) you can only open 8bit files.

You can use the PICprog2006 (set K8048 compatibility ON) and you can open INHX8M,16 and 32 files.

I have the same issue - using CCS compiler which generates a hex file that is reported to be in the wrong format.

I treid to locate PicProgrammer2006 - but the download page from the publisher only provides a link to PicProgrammer2009 I have tried this but, apart from frequent crashes, it does not apper to support the 16F873 that i am trying to Program, it will load the hex file but inspecting this manualy it seems to be corrupted (from manual view of the data. Alltogether it is not particularly viable.

Is there an old copy of PicProgrammer2006 available somewhere on the net?

Does anyone knok of any utility that perfroms a file format conversion?

Thanks in advance

I managed to work arround the error by manuay editing the CCS compiler hex output and removing the last two lines n the file from memory these were somthing like:

PIC 16F873
CRC xxxx …

Then using Progpic2

I then loaded the file and as long as I have disabled the write config the write cycle completes with OK, also the verify option runs and again reports OK

But when I Save the readback file I get a subtely different data than that in the CCS generated hex file (I am new to PIC’s so please excuse any stupdidity/naivety)

The first line of the CCS generated hex file is:


readback result is;


0000: 0000 3001 008A 29D2 30A0 0084 0800 1903
hmm just spotted it the byte order is reversed… :blush:

looks like ive answered my own question, and hopefully this might be a solution…

Have I missed any other gotchers? :question: I am not sure I can be confident untill i get some working hardware…