VM110/ k8055 - old Firmware -> timeouts ?! -> how to f


some months ago I bought a VM110/k8055 board.
I only bought it, because it was known to be able
to work together with linux.

During the months I again and again tried it with different
distributions and on different hardware, but I never got it
running. Sometimes I tried it on a windows-machine
with the Demo-software from velleman and it worked.
So the board is working, but not together with linux.

Some days ago I decided to subscribe the linux-usb mailing
list and ask the developers there.

The problem could be located: it’s a timeout-problem.
One of the people there told me, that he remembers there
was an upgrade of the PIC-firmware. After the update the
card should work, because the updfate fixed a USB-communication bug.

My card has the date “2003” on it, but it bought it some months ago.
Somehow I might have got a card from an old charge.

My problem is now: without an updated PIC the card is
completely useless for me. I bought it, because it should be able
to work togehter with linux, but if it does not fit the USB-specifications
and can’t communicate, I have a card thatI can throw away.

What I now need is an updated PIC.

If I could get the card running, this would be wonderful,
because I like, that it has digital as well as analog in/out.

Would it be possible to get a new PIC from velleman?

There are no upgrades made to the firmware of the K8055.
Velleman has no support for Linux but on the web there seems to be (as you noted) several Linux software for the K8055.

e.g. libk8055.sourceforge.net/

Hi, i’m using ‘testing’ the k8055 on linux.

I made a little howto

Hope this can help you out.

Regards Web.