Vertex Delta K8800 - Marlin Firmware 2.0.6

Just pushed the Marlin 2.0.6 firmware to github.
It’s a pretty plain 2.0.6 w/o any specials from the Velleman build.
Please configure according to your requirements.

The nasty display problem (swapped upper/lower half) was fixed by using a different LCD controller type (AZSMZ_12864).

It’s build with platformio, Arduino IDE is obsolete.
Build with “pio run -e K8800”.

Have fun…

Excited to try it out, just built my K8800 a few weeks ago, running stock Welleman firmware.
Just a heads up; you’ve duplicated the K8800 env section in platformio.ini

Sorry, it doesn’t work :frowning:
When building with your command line it fails when trying to link the elf.
Building with the Marlin extension works, but then the display contrast is unreadable.
I could read the display for a while, but when calibrating it failed with “probing error”.
Tried several times, but then after a power cycle the display was unreadable.

Edit: After flashing I was prompted that the eeprom was invalid, so I chose to reset.
Also, the rotary encoder was really sluggish.

Oh @#!@…
° platformio.ini - happened during rebase.
° contrast - because I didn’t powercycle the printer I didn’t notice it.
° probing error: probing radius is to large for stock printbed.

Stay tuned - I’ll push a new release the next days…

1 Like

Trying to compile your latest commit, but it fails when using stock bed.
Line 1165:


That should probably be:


Also, line 434 is missing a # before the if.

Line 917-919:

#define DEFAULT_ACCELERATION          (DEFAULT_MAX_ACCELERATION / 2)    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  (DEFAULT_MAX_ACCELERATION / 2)    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   (DEFAULT_MAX_ACCELERATION / 2)    // X, Y, Z acceleration for travel (non printing) moves

That’s not ok, since DEFAULT_MAX_ACCELERATION is an array.
I changed them to 3000, and now it compiles.
Going to try and flash now :slight_smile:

The screen is still almost unreadable, even @ 100% contrast.
But the probing seems to be working. :+1:

Jep - the repo wasn’t up to date, work wasn’t finished.

The next hour you’ll see a working one…

New build with fixed typos.
Changes (Configuration.h)
VELLEMAN_K8800_STOCK true|false
when true most of the defaults from 1.1.4 are used (height, probe radius)
E3D_HOTEND true|false
when true we use the E3D thermistortype, otherwise the stock Velleman
VELLEMAN_K8800_BED 0|1|2|3
0: stock Velleman printbed
1-3: various heated bed variants

Because of the changed LCD type the range for LCD contrast has changed:
MIN: 128
MAX: 255

The sluggish encoder should be fixed also.

1 Like

The display is readable now, and the calibration is working (a lot slower that the stock fw, but that’s not because of you, I guess the standard Marlin probing is like that).

Then before I was going to test print something, I did an “unload filament” wanting to change to a new filament I got, and that was a mistake…

According to the display the hotend was heated up to 190C before the extruder started to move. Then the motor began to stall, jerk and almost chop the filament, without being able to rectract it, almost as if the hotend was too cool.

Now this may be a coincidence, and something broke in the printer, I don’t know yet. But everything was fine yesterday, I printed a Benchy with your last commit (plus my changes to make it compile).
Now I’m stuck with a piece of filament in the extruder opening, so I can’t test no more.

No worries though; I was gonna take the printer apart anyways, doing the linear ball bearing mod by @Dr_Vegetable . Guess I have to disassemble the extruder too…

Will revert to stock Welleman firmware for now, until someone else tries out your firmware on a stock K8800.

Edit: The encoder is still sluggish, and it’s reverted compared to the stock firmware.

Sorry to hear…
° Did you set E3D_HOTEND to false? Otherwise you’d be off (colder) by ~20°…
° The slow calibration is on purpose, to have minimum effect on the piezos for probing.
I will encapsulate the slow probing values in "ENABLED(VELLEMAN_K8800_STOCK) in next release.

I’ll have a look at the encoder again - I’m using the config values from stock.

1 Like

This is what I changed:

// Heated Bed:

// 0 ... no heated bed - Velleman BuildTak

// 1 ... heated bed, variant @surviknows (PC1, PK0)

// 2 ... heated bed, variant @riodoro ()

// 3 ... heated bed, variant @susisstrolch (PC1, PK0, sandwich 220mm)

#define VELLEMAN_K8800_BED 0

// set to true to use settings from Velleman K8800 Marlin 1.1.4

#define VELLEMAN_K8800_STOCK true

// comment next line if you have a stock hotend

#define E3D_HOTEND false

Hmm, that’s really strange - especially that the filament is broken during retract.
Never seen that - mostly the extruder will slip.
So - if you’re still adventurous - I’ve rebased the repo and made the config more sane.

Velleman Vertex Delta K8800

° change LDC controller to AZSMZ_12864
  change contrast range
° set encoder direction to 1.1.4
° minimize changes to platformio.ini
  ° add platformio.ini.local as extra_config
  ° move env:K8800 and env_default to platformio.ini.local to ease
    push/pull from upstream repo
° cosmetic changes in pins_K8800.h
° add BOARD_K8800 to boards.h
° customize Configuration
  ° #define VELLEMAN_K8800_STOCK true|false to use stock 1.1.4 settings
  ° #define E3D_HOTEND true|false to select different hotend thermistor
  ° #define VELLEMAN_K8800_BED 0..3 to use different (heated) printbeds
  ° preset E3D_HOTEND false and VELLEMAN_K8800_BED 0 when setting
    VELLEMAN_K8800_STOCK to true
  ° enclose changes against stock 1.1.4 setting in
1 Like

I’m just finished with the linear ball bearing mod, and now I have some trouble with bed leveling :frowning:
When I’m satisfied with the mod, I might give your firmware another try :slight_smile:
Noticed the rebase, great, makes it easier for me to follow what you’ve done :+1:

The never ending bed leveling story…
I tried a little helper - a cup which is sitting on the piezo. At least with my print bed I got better leveling result.
if you’re interested about the idea(s) behind we can start a different topic…
(there a lot of piezo discussions on reprap forum, that one for example…,767998,875151#msg-875151)


Sounds interesting, please start a topic and share your details, if you like.

Tried to compile your latest fw with stock true, but it doesn’t work :frowning:
Configuration.h: line 452: missing a / for the comment.
Also, DEFAULT_XYZ_STEPS_PER_UNIT is undefined when stock.

Sorry - fixed and pushed. Compiles fine for stock and non-stock.