Velleman K8076 not identifying PIC

Hello everyone.
I assembled the K8076. I use windows 8.1 and usb-serial converter. I also tested this device on windows 8.1 native serial port.
I runned the harware test and every led is enabled/disabled synchronous to the screen display.

I put an PIC 16F630 to the ZIF sockel and power on the device, after connecting it first to the serial port.
I select Function->Identify Connected PIC in PicProc2009 and the PIC is identified as 18F4420 (and not as 16f630) in the sockel.
What I already tested:
Condensators - OK
Resistor - OK
Diodes - OK
Transistors - OK
ICs - Not tested

Used different PIC, same error
I tried different Serial cables, same error

I don’t know what else I could do to fix this problem.

Thank you for you help, Louis

The PIC is now identified as 10F200.
If I try to manually set the PIC, it only returns 0x0000 with exception to address
0x0126 which is 0x0001
the returned osccal value is 0x3FFE

  • Are you sure the serial port is also internally native ?

  • Did you already tried to increase the “hardware delay” parameter (–> SLOW) ?

The Hardware Delay was set to slow.
The second Serial port is native, yes.
I selected “read all” again now everything returned is 0x0000 and OSCCAL Value 0x3FFF the PIC is from a K8056, the other two are new ones. It appears to be reading the confugration properbly becouse I noticed the Code Protection flag disappearing.

I still have no Idea why the OSCCAL value is 0x3FFF. I do not want to write to the chip unless I read correct values.
This is the hex file from a newly bought 16F630

Same Problem here.
I 'm using a vm134 Pic programmer board and a VM142 PIC-PLC Module

Software PicProg2009 : "identify connected pic " has 18F4420 as a result

I connected the vm134 PIC rogrammer board to the VM142-picmodule via the icsp-port (5 cables straight from programming board to pic-module)

You know that all of the PICs for the Velleman kits are protected right?

… and that means??

I bought a vm134 and vm142 two days ago and honestly, until now I don’t have any idea how i’ll ever be able to adress input and outputs of the vm142… up to now I don’t ‘understand’ the thing…

Sorry my bad you should be able to program that one.
What kind of power supply are you using?
The programmer requires 12 volts unregulated or 15 volts regulated
Your machine needs to have a native com port.

Sorry about the confusion

You also need to keep the cables between the programmer and the VM142 as shot as you can


  • probleem is the same as the original post
  • PIC-type read is diffferent type even i put the pic directly in the socket on the programming board

I used the RS232 cable from the Velleman box. RS232 port is on the computer’s motherboars.
PS is 15V regulated

Sorry, we don’t seem to be able to solve this problem through this forum.
If desired, you can return your kit for inspection/repair to:

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere

or to your Velleman distributor.

I already tested every element (including ic’s) on the Board. All parts are ok (desoldered, testet, soldered again). Anyway i will send you the board. Maybe I overlooked something. I looked the net for other related problems, and people can manually set the pic type, then programm without problems. My Problem is that osccal values are not read ( returning 0x0fff for a brand new 16f630).
My only idea is that there is a problem with the pc hardware. Maybe my other computer does not have a uart 16550 compatible port. Is uart 16950 compatible to 16550? Then i will try a pci serial card.

Serial cable is 30 cm icsp cable is 5cm

Greetings Louis

Strange thing is that PIC is recognized as 18F4420 (and not as 16f630), just as in LisGer’s post…

I am also having a similar problem. My setup does not even show a option for a 18P IC. It only goes as high as a 16P, On start up it does not recognize my chip, if I go into function hardware and select K8048 Then I can’t do anything. If I go function- identify connected pic it picks the wrong chip. I don’t have any idea what to do next.

i got to work when i moved 0 to 5 Hardware delay
software PicProg2009
Hardware Configuration
Hardware delay 5

Sorry, google translator english.