Velleman K8061 Software

My setup:
Running Windows 10 64-bit
Microsoft Visual Studio Community 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.7.03056
Applies to VB.NET C# and C++

I have downloaded and manually installed the software components, I successfully ran the x64 test program that came along with the download. I can set outputs and see inputs on the K8061 board with no problem, works as designed.

My issue is when I am writing a program and try to test it, nothing works, I can’t connect to the board. I read through the guide “K8061_DLL_manual.pdf” and my code seems fine, no build errors or warnings. I’ve tried a few idiot checks by looking at the versions of files have been installed:
K8061.dll v4.0.0.1 1,572KB
Driver: K8061Driver_v1.0.0.2

I’m trying to learn what’s going on here because I can’t seem to find out why I can’t connect. What’s a good place to start troubleshooting?

You may try if the 32-bit version works.
Download the package “K8061 driver update v4.0.0.0” from:

Copy the DLL version to the folder \Windows\SysWOW64

You can try the demo projects in the package “Complete software package edition 2011”.

This solution worked! I assumed incorrectly the 64-bit DLL must be copied to \Windows\SysWOW64 in order to work on 64 bit Windows. I renamed the 64-bit version to K8061_x64.dll and copied the 32-bit version and kept the same name K8061.dll

Thank you for your help! probably will be ordering the last couple of these again soon!

Glad to see it’s working for you now :slight_smile:
Indeed, may be confusing, but:
64-bit DLL must be copied to \Windows\System32
32-bit DLL must be copied to \Windows\SysWOW64