USB Connection issue


We have a K8200 for a school project, however we cannot get to communicate to the board. We’ve tried the following (both with a Mac and a Windows 7 laptop):

  1. start the Arduino IDE (1.0.6)
  2. set board to Arduino Mega 2560 / Mega ADK
  3. serial port on USB
  4. connect USB cable, both leds (red/green) stay on - no power plugged yet for printer
  5. tried to compile and download a simple program
  6. we get an error “stk500v2_ReceiveMessage(): timeout”

We tried with different port setting, changing speed, different USB cables etc. to no help.

When we turn the power on and connect with Repetier we can send commands to the board but nothing happen.

What should we do ?

Thanks in advance,

Why did you start the Arduino IDE? Was it necessary to upgrade the firmware of the board? Did you test the board before you attempted to upgrade it? All recent boards carry V2 of the firmware, so there is no need for an upgrade.


The reason why I tried with the IDE is because there was no response from the printer whatsoever and I wanted to check if the board itself was ok.

I’ve managed to fix this by resetting the board once again, setting on a Mac Repeteir 0.56 the printer as “tty-usb” (not virtual printer), speed of 115200.

Now the printer is responding again.

Thanks for the help and suggestions so far,