Updating firmware-error: avrdude stk500v2_receivemessage()


I want to update the firmware and downloaded it from Github, keep running into the same problem and get the message:

avrdude stk500v2_receivemessage() timeout

This happens on three different machines:
Mac OSX 10.11 El Capitan with CH340 drivers (latest version I could find where 1.4, but also tried earlier versions)
MacOS Sierra 10.12.6 Sierra with CH340 drivers installed
Windows 10 both with stock CH340 drivers and upgraded drivers.

I also have tried 2 different USB cables, but that also didn’t make a difference.

What happens is that I can select the board, processor and port in Arduino (1.8.1). I can request the Board Info, but when I upload I get the message I mentioned before.

I don’t have a clue what to try anymore, does anyone have an idea how to solve this?


You have to connect the two JPROG pins together.
These are located near the USB connector.

Thank you!
That indeed solved the issue and relieved me quite some headache :wink:

You’re welcome =)