Two Days K8800 and disappointed

Two days printer owner and very disappointed…

I bought the Vertex Delta two days ago.

The assembly was easy, even if the manual really could be improved!
Due to the large pictures the overview suffers. Better would be small pictures
because the pictures enlarged by clicking anyway.

Where is a detailed description of ALL menu items?
Where are the German translations of the documents beside assembly?

The assembly was done with great care and took about 4 hours for me.
Everything was done exactly according to instructions. Mechanically everything seems to be ok.

The next day first-time setup took place.

The printer performed an automatic calibration as described. The calibration sensitivity was checked before and is very high.

Nevertheless, during the first automatic calibration, the print head always hit the print bed with a distinct audible click. What I thought it would be correct - at this time – now I know better.
The calibration was completed with "successful"

I followed the instructions and tried to execute "CALIBRATE X, Y, Z, CENTER". Nothing happened. Then I stored settings as described and tried again. The result remained the same.

Then I’ve selected “Auto Home”, “Calibrate Hight” and “Auto Calibration” multiple times.

The printhead always stayed directly under the light barriers (without the "safe distance") and only performed the "light barrier test". In "Auto Home" and "Calibrate Hight" always once each and in "Auto Calibration" always three times. Multiple power-cycles had no effect.

So I selected "Restore Failsafe", which seemed to me the most useful in this situation.
After that, I chose "Auto Calibration".

The print head drove at full speed straight down into the print bed!
Only "Power off" stopped the steppers!

Power on again and I chose "initialize EEPROM".

Again I did "Auto Calibration". Now the print head does not hit the print bed so hard anymore
during calibration. Printer seemed to be OK then.

Then the first print test:

Data on SD card, loaded in the printer, printing started with calibrating the print head,

I think, because saw that I forgot to load the PLA down to the print head, I wanted to stop the printing at this point. So I selected “Cancel printing”

The print head moved sideways and then again crashed into the print bed!
Again the steppers could only be stopped with "Power off"!

Mature firmware ???

Power on, "Auto Home", "Auto Calibration" -> OK

Next print attempt -> object gets loose from the print bed.
Canceling via the menu this time works without "head crash"

Third print attempt -> object gets loose from the print bed again.
Canceling via the menu this time also works without "head crash"

Are 10 meters filament for first testing really too expensive to include?
Better leave the tools away!

Filament used (because I could not get other in short time)
Renkforce PLA 1.75mm Red 485c, Printing Temperature: 190 - 220 ° C
Used temperature: 200 ° C.

This should work, or?

What else can I do so that the workpieces stick to the bed better?
And how to print plastics other than PLA without a heated print bed?

Conclusion after two days K8800: Two quirks in the print bed and no successful print.


Can you post a video of what the printer does when you select “Calibrate Height” and than after it has finished select “Auto Calibration”


As I wrote before, I think “Calibrate High” and “Auto Calibrtion” are working normal now.
I was able to do at least two good prints.

But today, the printhead hit the bed again! I tried to print the “extruder upgrade”

As i stated the print, I recognize that I had tuned on “brim”.
So I selected “stop printing” and immediately the head crashed in the bed again.
Again I had to switch off the printer to stop the steppers!

3. Hole in the printbed now!

And also the filament sensor does not work correctly!
It’s working for a while and then it’s not recognizing the filament. I had to reload filament 6 times during one print! And then, netxt print - same data and same filament - everything OK.
Next print: fail again.

This “sensor” constuction with the microswitch is good for nothing!
Even more disappointed today!

The filament sensor may not be the problem but more with the filament.
If you measure the filament diameter in several places you find that it varies.
This is what is causing the sensor to trip.
You can always disconnect it.
Look in this link.

Do never cancel a print while the printer is not printing with the default Velleman firmware, it leads to what you say, a crash. If you want to cancel while it is warming up to 130, leveling bed, priming, power cicle or you will crash. You can cancel the print normally if the printer is printing

Been reported long ago, but the official firmware was never updated

Regarding filament, this fixed it for me: Filament detection problem, the source of all evil?

Prints should stick to the default bed. Have an initial layer height of 0.2mm at least

Firmware is original. But I thought of compiling one with the current version of Marlin to maybe get rid of this malfunktions - Better not?

Yes, that is also my experience.

I think revising would actually be cheaper than having to support customers for something like that and then losing them because of dissatisfaction …

Not always :frowning: I had one crash in thi Situation also.

:slight_smile: without knowing this I came to the same solution. It’s working now. But only for the moment I think - because this sensor-constuktion is not really good. Filament is actuating the trigger more or less directly. There should be a different lever-construktion to extend the actuating-travel-distance.

This problem occured only with the first two prints. I changed from brim to raft and it worked.

Some people here, including Velleman will tell you that the firmware doesn’t need an upgrade and that the technicians are in holidays… And they are validating Marlin older version since a year… So you won’t see an update from Velleman in the near future. But yes, flash to latest Marlin, you’ll be better off. I did not compile on my github, but I have started the marlin portage. Stopped because of many reasons, time being one and lazyness being another.

Re filament detector. Well, you saw when I posted this and also noticed that none from Velleman took the time to answer. For me it fixed it, but as you said, the construction is really bad and I ended up gluing it on place. I started designing a new extruder yesterday (being the reason of my visit here again, to see if anybody else already did it, otherwise I do not visit this toxic place), because this one will not let you print Ninjaflex as there’s too much place for the filament and it ends up rolling in the extruder jamming everything. Will share the extruder once I have it working correctly

I think revising would actually be cheaper than having to support customers for something like that and then losing them because of dissatisfaction …

Well, how to tell you that… They don’t care, experience made

Did you manage to get the latest Marlin firmware working on your Delta?

“latest” is the one I was working on when I said I’d do it yes, I never updated since, no time, no envy, no use of the delta etc

Disappointing to find out the stock firmware hasn’t been updated in years

1 Like