Try to start a print and printer goes unresponsive

Hello everyone,

At first this may sound like a computer or firmware problem, but please bear with me until I get through my explanation. (Thank you!)

I’m having an issue with my printer where, whenever I try to start a print, Repetier will try to continue sending commands to the printer, but the printer will become completely unresponsive. The heater bed will heat up, but the extruder heater will not do anything. Once it gets to this state, it will constantly report back the temperatures, but I cannot manually turn off or on any of the heaters or the fan, nor can I go into manual control and move any of the motors. The only way I have found to get the printer out of this state is hitting the reset button or unpluging the printer. I have tried to heat both the extruder and the bed while only in manual control without hitting “Start Job” and both heated up without a single problem.

I have tried updating the firmware and I have also tried different computers, and no matter what I keep getting the same issue. So I have ruled “computer/software” and “firmware” out of the possibilities. The only thing I can think of being a possibility is an issue with the board. I built the printer over the summer, but then left it when I went off to college. Before I went off, managed to get it to start extruding, but the settings were still really rough and it was messing up on prints midway through. No one touched it while I was gone and once I got back it was doing this. It was in a room that is regularly kept at a minimum temperature of about 13 degrees C and I highly doubt humidity or water messed with it.

Is it truly a problem with the control board? Is it fixable? Is the control board dead? Is it a different issue that I didn’t come to realize?

Any and all help is be appreciated. Thank you.


I don’t think it’s the board that is faulty.

If i get you correctly the problem happens only if you start a print job, right?

Does repetier show any error messages in the log?

Check your printer communication settings first.
Serial connection chosen?
Baudrate 250000 ?
Reset on connect disabled?
cache size 63?

Sorry for the delayed response.

No, Repetier does not show any error messages.

Yes, I have the printer communication settings set to Serial Connection (COM3; it properly connected), Baudrate of 250000, reset on connect disabled and a cache size of 63.

what happens if you disconnect both heaters before starting the job ?

By that, do you mean unplug them from the board?

EDIT: Just tried running a job while the plugs for the bed and extruder heaters unplugged. Same thing is happening; the light for the bed heater is on, but the light for the extruder heater is off. Also, it’s still doesn’t respond to a kill command, or even an emergency stop.

Okay, then measure the resistance on the unplugged extruder thermistor connector and heatbed thermistor connector.
Tey both should read about 100kOhms at room temp.
Maybe there is a short in the wiring.

I am indeed getting 100k Ohms.

Okay, you wrote the heaters work when in manual mode right?
Do both heaters work switched on together manually?

There can be an issue with the endstops too.
Disconnect them and measure on the connector if they switch correctly if you press them manually.

The extruders do work when manually turned on, even both at the same time.

Sorry to ask this, but would you mind explaining what you mean in the second part of your previous post? The endstops? I’m still pretty new to all of this.

I suggest you to disconnect the endstop switches and measure on their connectors if they switch on and off correctly.
If the endstop switches give a stop signal during print or are faulty the print will hang.
Normally you then should see an endstop hit message in the log.

Does homing work correctly in manual mode?

I should have realized you meant the X, Y, & Z stops when you said endstops. I’m sorry.
Yes, homing works just as it is supposed to.

Well, then the endstops should be ok i think.

You said you updated the firmware.
Which version did you use ? V2?
V2 disables the endstops during printing, which will prevent stopping due to the bed slightly hitting the endstops while printing.

And more important, which arduino version did you use to compile and upload it, 1.5.8 ?
I found 1.5.8 does not work correctly. If so, get 1.0.6 and try again.

Also important, did you reload and the save the default firmware settings (in repetier Firmware eeprom config) after updating?

I updated the firmware to V2 for K8200, which should allow it to use the VM8201 SD card reader module and something else if I remember correctly.

I read somewhere else on the forum about how the new versions of the arduino software would compile the firmware wrong, and that 1.0.4 was a good one to use, so I used the 1.0.4 version to compile and upload the firmware.

Just reloaded the default firmware settings in Repetier and saved them to the eeprom config. Tried to print again, and same problem happened.

EDIT: I’d also like to note that this problem happened on the V1 firmware as well. Same exact issue with same exact symptoms.

Did you watch the blue light on the power supply whenstarting a job?
If it flashes or goes off ther may be overload.
Best to check for sure is to measure the power over the 15v input when starting.
If it dips there is a power problem.

So, i go home now, as it is already 22:00 at my location.

Feel free to post more questions, ill answer when i’m back.

Blue light on the power supply didn’t change at all. Stayed constant and at the same intensity.

When on standby, my multimeter says that the voltage at the terminals is 15.36V. When I went to check the voltage when I start it it went down to 14.99V and then fluctuated between 14.99V and 15V. Is that a significant enough dip to be an issue? Even though, while on, it’s essentially holding steady at 15V?

Thank you for your time today, ichbinsnur.


Just some basic things to check.
In the printer settings.
Baud rate: 250000
Reset on Connect: Disabled
Make sure the power supply is as far away from the control board as possible.
Are you using the USB cable supplied with the printer?
If not please try it.

The usb connection indeed may be faulty.
Check the usb cable as wrong way suggested.

If that doesn’t help, pleas disconnect all plugs from the controller board and
post a high res picture of the pcb. Especially the area around the usb connector.
It is easy to break.

Hi, I also had this problem. One of the power cables was a bit loosely attached and one of the screws was not tight enough. Anytime the printer did a large move the cable lost contact with the main power in then halted. Perhaps one of the power cables are loose, I made the contact area of my cables larger and opened up the screws fully, put them in and tighted firmly. Also my controller-board was a bit loose so that it could shake. One of the plastic rings was squished. Contributed.

Did you manage to get your printer going. I am having the same problem as you so I am interested to know whether you found a solution.

Many thanks.