Too much filament during infills

Arduino 1.0.6 used according to manual and then there was nothing more in the display of the printer than just a blue screen … (?)

Use the Arduino-1.5.4-r2 to upload.
Reinstall only. The Marlin.ino file will be where it was.
Dawnload Arduino 1.5.4 beta

Arduino 1.5.4 beta used fully uploaded according to manual Marlin.ino and the printer’s display is still only a blue!

This is definitely Firmware for K8400 ?
Try the latest one Arduino 1.8.12

Here you have configuration files.

In config/example/velleman/K8400/…

And more from forum

I’m slowly but surely sinking into a swamp.
More on the Forum: these are old Topic’s and they only talk about Arduino 1.0.6.
When I Upload no error is generated at all and apparently it goes as it should.
Do you work at Velleman or are you also a user of this printer?
Do you live in the Netherlands?
Greet Auke

I don’t work for Velleman, I’m just a hobbyist. I use K8200 which I have moded many times through K8203, K2804 and this year I have rebuilt 3/4 of the printer.
Here is a little more about the project:

I live in the UK but if you want send a prv and your configuration.h (I will check) , or think about changing the firmware to Marlin 2.0.x bugfix and in bugfixConfig you have firmware for most printers.
And in case of any problems I will help.
And with Marlin 1.x there were always problems (different versions of Arduino for different things) I had the same problems as you now. I am not able to check for you because I am now using the motherboard Mega2560 / Ramp1.4.

Thank you for your answer and help. I am a 69 year old man who has been at the computer for many years but does not have that much experience with programming. I have done something with C ++ before and I know what it looks like in terms of content, but I don’t know anything about programming anymore. Do you think it’s the software that the printer’s display is no longer working?
I have the K8400.
Do you want me to send you the Marlin.ino file? How? You can’t add a file, can you?

Greet Auke

Ok then
Start by copying and saving in a safe place the current firmware from c: / … documents / arduino (Marlin directory).
Download the configuration files I gave above.
Unzip and find in the ’ Config / Example / Velleman / K8400 ’
Now copy and paste into the C: / … Documents / Arduino / Marlin directory
Now try to upload using the Arduino IDE version recommended in the forum.
So we check if it’s wrong firmware or ArduinoIDE

Hello again,
I downloaded the files from the site you said, so the complete software of the printer, I copied the two files to the Marlin folder. Then the Marlin.ino updated to the printer and immediately got the error message see below.

I still had an old Marlin.ino file from 2016, which I have now uploaded to the printer and yes again image on the display.

Now I looked up the Movement settings in this file at Configuration.h to put the value you indicated in this, but see other numbers.
#define DEFAULT_AXIS_STEPS_PER_UNIT {134.74,134.74,4266.66,200} //
in the previous series I showed you, was; “default steps for Ultimaker”(?) behind, so not in this series.

I checked configuration_adv.h for the Microstep setting K8400.
these are the settings from the example configuration
I think it should be like this

E= ( number of steps(200 for 1.8’ or 400 for 0.9’) x microsteps(1/2/4/8/16) mode x ratio(1 for ndirect) ) / ( pi x diameter at the point of contact with the filament(13.50 In this case. )


But it will be best if you test it

I have tested with these last settings, but it does not get better after following me too little material.
Below for the changes and above after the last changes.

I was looking at your previous reactions again and see that this table shows two different printers.
The K8203 and the K8400. Now you give me the E size of the K8203 and as you know by now I have the K8400. So now this E-measure recorded and installed. The prints have gotten a lot better. Only the first layer can have a little bit more.
I now let the printer go and will show the compete result.
Greet Auke

Now I am very happy with the result. The top one printed much earlier and with a lot of cutting, the bottom one straight out of the printer with little or no hair wires. Just have to do something about the drawing to get more profile.
Thank you for putting me on the right track.
Greet Auke

And what will it soon … The Schloss of Limburg a/ d Lahn Germany scale 1: 200.
See also
Drawn in SketchUp.

I’m glad I could help.
What layer thickness settings do you have for this?First layer 0.2, layer 0.1?

And what value did you give for extruder steps?


Do you make models?
I design something for my children :slight_smile: From WOW or Minercraft. I am just bored.

Good morning,
I now print with layer thickness 0.1mm first layer 0.2mm.
Do you print two colors together?
I am a member (chairman) of a model railway club in Zoetermeer. The Lahntalbahn Model Railway Association, visit the website for more information. There for I am building buildings, also the Schloss van Limburg.

Geprint model fase 5
On the rightside I’am started years ago but I don’t that’s nice enough, so I doing that part again.

Yes, this is a two-color printout with a 0.2mm layer. Prepared in CURA using a prime tower.
I am still modifying CURA configurations.
I saw the page you showed, Very cool, but I didn’t read too much :slight_smile:
Do you design print models yourself?
Maybe I could somehow help with the design, I am looking for something to do.
Regards Marcin


Dear Marcin,
I owed you this answer.

Hello Marcin,
I started a new topic “Position Y-axis shifted.” Maybe you can help me with this problem.
Greet Auke

Hello Marcin,
Not printed for a while but started printing parts again and this went just as well. Until I set the layer thickness to 0.1 for a more detailed part and the extrusion width to 350% as you explained to me earlier. But this goes completely wrong again. The first layer I have at 0.2. The flow speed of the filament is so low that only very thin hair threads are made. And therefore not a good first layer.
I thought the Eeprom settings would be out of order again so I uploaded it back to the printer. According to Velleman’s rules. But this did not help.

A question: do the microsteps have a connection to the movements? Now this number (150,979) in my printer K8400 with Microsteps = x32 is calculated. Doesn’t this have to be changed to 32 with microstep at Configuration_adv.h? Now here it says #define MICROSTEP_MODES {16,16,16,16,16} // [1,2,4,8,16]?

If I set 75.48950 at Movement; #define DEFAULT_AXIS_STEPS_PER_UNIT {134.74,134.74,4266,75.48950} //. then the filament transport goes too fast, too much pressure is put on the filament (the filament then slips back between the drive wheels). If I do it with 150,979 (as I had done this before) this did not occur, so put it back in Malin.

The filament unloads and loads again, but now the filament stops in the feed tube up to about 150 mm in front of the extruder and then advances in small steps, but not enough to get to the extruder ???

It is getting weirder. I hope you want to help me with this too.
Greet Auke