Stepper motor skipping

Hello everyone,

I’m having some issues with my Vertex K8400 printer. the issue is that my Stepper is motor is skipping steps which is resulting in shifting layers.
I’ve been reading a lot on the forum to what could cause it and how to fix it but I’ve been unable to fix it.
I’ve made sure the XY carriage is smooth, when i tilt the printer 45 degree the print head is able to slide to the other side on all axis. I’ve also checked the stepper motor voltage and made sure it’s between 0.89 and 0.925.
I’ve made some videos of the XY carriage sliding when the printer is tilted and of the stepper motor slipping, which always happens on the same spot.

XY carriage sliding video:

Stepper motor slipping video:

Also I’ve been able to print before with the printer and it used to work pretty well I’ve made some nice prints with it.
I just noticed this issue when i tried to print something out that needed the whole print bed surface,
at which point i tried to fix it, every time I take off the belts and try to fix the issue of the stepping shifts to a new position.

Hope someone here knows what my issue is and is able to tell me how to fix my printer.

with kind regards,

Once tried to decrease the acceleration? I had this problem.
Settings-> Motoin-> Vxy-jerk to 8.
From then on no more shifts while printing.
Kind Regards. Bart

You should look at this page.

Hello Bart, thank you for quick response, i did already tried that one time i have lowered the Vxy-Jerk to 5 already and that didn’t help, the video i posted was with Vxy-jerk on 5, one of the reason why i’m asking here because i feel like I’ve already tried everything.

Hello Wrong_way, thank you for your quick response, but I’ve already followed all the steps on that wiki page, i even printed out the XY-Carriage Alignment Helper (by H60) from thingiverse to align my carriage when I put the belts back on. but I still have the same issue.

I have watched your last movie. It looks to me a problem with the drivers or the control. What I would try is to bring the control of the z axis to the x axis. See what happened. If good, exchange the drivers, see what this gives.
Kind regards Bart.

Did you use the alignment helper when you attached the belt?
in the video it looked like it was hanging in the middle of the Y axis almost like the assembly was getting pinched in that area try moving the print head from the front to the back and the back to the front by hand watch the belts that drive the Z axis to see if they get loose and sag a little but or get tight.
This will tell you a lot.
Do the same for the X axis

Hello Bart,
I tried exchanging the drivers like you said but that didn’t work either.
so i exchanged them back but now I have a new Issue, when i tried the auto home,
the X axis moved but the Y axis didn’t move and instead i could loud beep noise as you can hear on a new video i made.

edit: I found out the cause of the beeping noise, the driver board weren’t fully inserted into the main board so the main board was sending out an error as a beep.

I also noticed that I have 2 slightly different Driver Board as you can see in the picture below
One is a DRV8825, 4CTC, CNG3
the other is a DRV8825, 4CTC, CENC
I don’t know if that makes any difference as they are both DRV8825

Kind regards Guillaume.

This is a screen capture from your second picture and you will need to verify this.
But it looks like some of the pins of the driver board have either very little or no solder on them.

Hello Wrong_Way,
I checked the solder and everything is fine, the pins you’re pointing at look like that due to the reflection of my light
Also i believe I’ve found the issue I’ve been having, it looks like my issue might have been caused due to my belt tension being set to tight

I forgot all about the belt tension
You should look at the solder joints under a magnifying glass.
The top of the pins do not look like they are soldered.

Is it solved?
DRV8825 This is the stepper-IC, what is written after is version or production does not know correctly. But its in execution of function the same.
Kind regards, Bart.

Hello Bart,
It’s not solved just yet, I’ve loosen the tension on the belts, now when i move it by manually the stepper motor doesn’t skip steps. But when i tried a test print it still skipped steps, so i wonder if it’s the belt tension or if i should lower the acceleration on the print, cause the skipping happens when the printer accelerate to the next spot, but it always happen around same Y level, which in my opinion is weird as you would expect the skipping to happen more frequently if it was an acceleration issue.

Kind regards, Guillaume.

Is the friction resistance across the whole line the same? The belts and the polys aligned? The screws of the poly still firmly fixed all of them?
The acceleration still stands at 5?
It is not easy if it is not in front of you and another language.
Kind regards Bart

I just checked, the Belts and Polys appear to be aligned, the poly is still firmly fixed, but i do find that there is some friction resistance on a few spots along the Y axis, it comes and goes.
what language do you normally speak if i may ask ? I’m personally from the Netherlands.

Kind regards, Guillaume


I am in the USA and only speak English (if you are asking me)
The end caps may be to close together or to far apart.
That why I asked you watch the belts as you slide it back and forth.
This will give you an indication of which way to move them

Just tap it you do not want to move it to far.


I’ve already did that and i thought i had the right clearance as i can easily move the rods in and out, is there a way for to find out though it have to bring the clamps closer or have to hit them away from each other ?

The only way I know of is to watch the belts. going in the other direction.

Ik ben een Belg.
Is er geen beschadiging aan uw as waar uw y as over glijd? Een braam, kras? Zijn de glijbussen nog oké?Voldoende smeerolie?
Vriendelijke groeten Bart.

I am a Belgian.
Is there no damage to your shaft where your y shaft slips over? A burr, scratch? Are the slides still okay? Sufficient lubricating oil?
Kind regards Bart.

Ik heb net gekeken naar mijn as en die ziet er goed geen krassen of wat dan ook,
als de aandrijf riemen niet vast zitten dan glijd het zonder probleem of frictie, de frictie krijg ik pas als ik de aandrijf riemen vast zet. De verstand wat ik krijg is rond het einde een beetje en net voor het midden, ik heb gekeken of de as gebogen is maar dat lijkt er niet naar uit. Ik zal wel wat olie toevoegen en kijken of dat beter gaat
Vriendelijke groeten Guillaume.

I just checked and the shaft appears to be in good condition, i don’t see any noticeable scratches.
when the belts are not fasten to the carriage then i don’t feel any friction what so ever, i only feel some friction when the belts are fastened to the carriage. the friction happens a little at the end and right before the middle, i already checked to see if the shaft was belt but it doesn’t appear to be, I’ll add some more lubrication oil to see if that helps.
Kind regards Guillaume