Starting GCode Issue


I use the following code when I start my prints:

M218 X0 Y0 T0 M117 Homing Axes G28 ; home all axes M117 Priming Extruder M83 G1 E8 F100; Prime Head M82 G92 E0 ; Reset extruder position G1 F1000 Z10; Move head up G1 F4000 X180; Move out of blob M117 Printing...

A lot of the time no plastic is extruded, but sometimes it is. Both cases have occurred using the same gcode file, so I know it is an issue with the printer and not the g code, although there may be a way of writing the code so that the printer will be able to follow it.

Does anyone know why this is happening or how to fix it?


Have you checked if your nozzle is clogged?
What if you trie to extrude manually in Repetier? 10mm, 50mm, … does that give any effect? Also mark your filament with a black dot and check if it indeed went 10mm and 50mm by marking a second not once the extruding is done.

Thanks for the reply. I should have been more clear about the issue.

The printer is not jammed or clogged - it simply ignores the command. After the starting gcode it prints just fine. I know it is ignoring the command because the extrusion should take a couple of seconds and the extruder motor should move. When I run the gcode and there is no delay between the previous command and the following command. The code is just not executed.

In your start G-code, there’s no command to heat up the print head. So it’s normal that the prime command is ignored.

Check here the Vertex default start g-code :

G28 ; Home extruder G1 Z5 F{Z_TRAVEL_SPEED} G1 Z0 F{Z_TRAVEL_SPEED} M106 S165 ; Turn on fan G90 ; Absolute positioning M82 ; Extruder in absolute mode ; Activate all used extruder {IF_EXT0}M104 T0 S{TEMP0} {IF_EXT1}M104 T1 S{TEMP1} G92 E0 ; Reset extruder position ; Wait for all used extruders to reach temperature {IF_EXT0}M109 T0 S{TEMP0} {IF_EXT1}M109 T1 S{TEMP1} {IF_EXT0}T0 {IF_EXT1}T1 M83 G1 E10 F100 M82 G92 E0 ; Reset extruder position M117 Vertex is printing G1 F1000 Z5

Try using it and check what happens.

Thank you for the reply.

By “bed” I take it you mean the printer head?

If so the printer head is already hot by this point. I’m using Simplify3D and this is the code that is executed after the head is at the correct temperature and before the print begins. I cannot add any temperature adjustments to this Gcode otherwise it will override what I define in the software itself.

The “bed” always means the bed which some of us has switched for a heated bed. It is controlled by M140 command.

The M106 command sets the fan speed to 165 of 256 of 100% speed.
The M104 command sets the extruder temp but in the example above no temp has been set.

You canlearn about all commands at:

Just compare the starting GCODE from raby and yours. There is for each nozzle a temperature setting :

M109 Tx Sy

Without this setting the nozzle will not heat up. This is not preventing the printer from XY movement, but a firmware internal check will release any extruding movements only for nozzle temperatures above 150°C (firmware internal constant). As temperature value the reading from the active nozzle is taken. There is no notification for this event, so despite moving in x, y and Z direction nothing else happens.


The temperature is being defined by a piece of Gcode before this Gcode, which is executed when the nozzle has reached the specified temperature. I’ve found that if I stop the print and then start it again, it usually will extrude as shown in the Gcode I gave.

Any ideas why this might be happening and how I can fix it without adding temperature commands to the Gcode above? If I add temperature commands I’d have to manually change it every time I change the temperature.