[SOLVED] OctoPi image will not boot

I don’t know if this is the proper place to post a question like this but I’ll try anyway.

I received my RaspberryPi 2 today including a Noobs SDcard. Of course I want to use OctoPi as it comes preconfigured for a ton of things.
So I downloaded the OctoPi image and using Win32DiskImager I copied the unzipped .img to the formatted SDcard.

When I thry to boot the raspi, nothing happens, I get a nice colorful gradient on screen but nothing more.
To be sure the raspi works normal, I copied Noobs on the SDcard which runs fine.
I have managed to install OctoPrint maunally but because of many system settigns I need to tweak I still like to setup OctoPi…

Has anyone experienced the same issues while trying to copy/use OctoPi?
How did you fix it? I’m using the stable if I’m correct.


If you have a RPI2, the old image for the RPI B+ will not boot.
It has a new processor… and as such, will need a different boot image.

Built your own, following the OctoPi wiki page
Or wait, until someone builds one.

Thanks for the quick answer Moki.
Since I’m not a real Linux expert, I think I have to wait until a newer image becomes available. In the mean time I’ll try to get the default Raspbian image/OctoPrint to work.

After finishing a manual setup of Raspbian/Octoprint/Webcam I noticed that since today, a raspi2 compatible image has become available on Octopi’s Nightly builds.
downloaded the image and it’s booting fine! I haven’t had the chance to actually print something but that will be the next thing of course ;).

There are one or two bugs with OctoPrint.

I slice on my PC, then upload the gcode file to my OctoPi (which can be very slow for big files).

If you have two nozzles, you will notice something rather odd if you elect to print from your left hand nozzle. OctoPrint gets its nozzles mixed up initially, then just as it starts to print, it switches them round and gets them right! Can be a bit confusing - check which LED is lit up when it starts to heat.

The other thing with OctoPi is that you have to sometimes manually control the fans (off / on). Not sure why they don’t turn off at the end of the print, but it’s no big deal. One slight annoyance is that OctoPi doesn’t lower the print bed at the end of the print the way I’ve got Repetier Host to do. I assumed RH put that in the gcode, but apparently not.

Beware that if you log in all day to watch your printer via the camera, it does use large amounts of data… :-0

I believe that the end position is set in Repetier which is only triggered by a Repetier event like print finished or print killed. I hope to find a solution in Octoprint for this someday. Maybe Octoprints eventhooks?