[SOLVED] K8048, demo1.asm, LEDs NOT blinking! Need help!


I finished soldering the K8048 kit and put in the PIC16F627. I connected a 12V 300mA power adapter (where one can choose voltage between 3-12V) (don’t have another one currently).

I connected the board via serial port to my pc, compiled demo1.asm, loaded it in the PicProg2009 and wrote to the PIC. Then I made a “verify”, this also seems to be OK.

Now I change the switch to RUN but nothing happens. The green power LED is on, the big red LED is blinking, nothing else happens.

What can be the cause? If a put a jumper on JP3 then LED1 goes on and stays on. (This shows me that there should be enough voltage!)

Should I check the soldering? What can I do?

Just a guess,

It sounds like you are using a 12 volt regulated supply.
This will not work
You need a 12 volt unregulated or 15 volt regulated power supply.

I hope this helps.

May I ask why? Does the “RUN” mode consume more power? I mean everything else seems to work without problems (programming and verifying of the PIC). Even the LED1 goes on if I touch the jumper as I wrote above.

//edit, I have found a notebook adapter with 19V DC (3 mA), I guess this is too much and would kill the board? :slight_smile:

From reading other post I think 15 volts is the highest you would want to go over that

judging from the appearance of you picture you did not select K8048 instead you are trying to write to the K8076. When you select K8048 the picture of a board in the top right hand corner is grayed out

Have you tried to connect both jumpers ( J3 + J4 ), it’s necessary to get the oscillator running in XT-mode !

( Got curious, found my board with a controller, same demoprogram, pulled of J4, SW5 in “RUN” po-

sition, same behavior as your description, then put back J4, no problem… )


GREAT!! That’s it! After I connected both jumpers the demo runs!
Thank you very much for that answer! :slight_smile:

I did select K8084, you can see it in the window title of my screenshot.