SOLVED: Endstop problems (not activating)

I have just built the K8400 and have a problem with end-stop function.
When performing the “home” command from the operators panel for the first time the steppers continue to operate even after end-stops are reached.
The circuit boards have the red light on so power is there but the function is not. I haven’t upgraded firmware or made any alterations, the instructions on-line have been followed 100%.

Any ideas?

Check if the print head hits the pulleys when homing. If the head is stopped mechanically before the endstop is activated, you may have such a behavior.

No the printhead assembly don’t hit the pulleys before the “pins” has gone through the sensors unfortunately.
Thanks for the tip though.

Right, I ran the system with the pulleys loose and activated the sensors with a screwdriver and it worked.
The problem must then be with the alignment of the belts and pulleys even though I cannot see what since the “pins” enter the sensors.
Back to realignment of this.

It was the alignment that caused all problems. Very sensitive on this compared to my Printrbot simple Metal.

How did you align it properly?

I have (had) issues with this too.
This is the instruction from the assembly:
The Y belts are quite tight and I still have problems that the Y endstop can’t be reached. The motor belt starts jumping 5 mm before the stop. So I have prolonged the “pin” so that it stops a little earlier.

So, first try to readjust the alignment of the axes. Here is a similar thread: Calibration. How to fix it?

When my printer was sufficiently aligned, I printed these to help improving the alignment:

So even after this alignment, I am not 100% satisfied with the alignment, but it works. I should double check the distance between the clamps sliding on the Y-rods, too.