Slic3r does not run


i did sucsessfully installed de Repetier host sofware and calibrated my Printer.

I followed the steps by the manual but the slic3r sofware did not start after actuating the configuration buttom.

I cant configure the slic3r…can you help me…?

Hi Isvouga,

which operating system are you using?

Which version of Repetier Host and/or Slic3r did you install?

Have you tried to start the Slic3r executable on its own, independent from Repetier Host?


Hello Kuraasu,

I have Windows 7 installed on my PC, i tried RH 0.84 at first,but the slicer sofware did not start with the link of the repetier bottom. So i installed RH 0.90 and tryed again with the same way and still it doesn´t run the slicer.

Running directly the executable the slicer started , but after uploading the PLA .ini / ABS.ini it seems that the sofware didn´t assume the parameters.

Grateful for your help



In Repetier, click on the Slicer tab, then the Manager button over on the right. Click on the Browse buttons to select your configuration directory and Slic3r executable.


@steve_b: that’s a valid point. However, if Slic3r is installed in its default location (subfolder inside RH’s directory), then RH should also find it with default (i.e. blank field) settings.

@Isvouga: if Slic3r runs on its own, it’s a good start. After loading a set of parameters from an .ini file, you need to save the settings in all three tabs (Print, Filament, and Printer), otherwise they won’t be transfered to Slic3r’s config directory. If you want to have a look inside that folder yourself, it’s in AppData\Roaming, or simply %appdata%\Slic3r.

If you want to do a fully clean reinstall of RH, also should also clear the config, just to be on the safe side. Unfortunately, RH stores it’s settings in the Registry, so it’s not as easy as in Slic3r’s case, where you just delete the above mentioned “Slic3r” folder (or rename it, if you want to keep your settings for future reference). In the Reg editor, RH is located at HKCU\Software\Repetier. Or, in case of the Velleman-branded RH, at Software\repetierVelleman. The whole key (i.e. folder) can be deleted, preferably after deinstalling RH of course.