SD card reader does not read the card

I’m having problems with my SD card reader.
I have several (3) cards and the reader show the same problem with all.

I prepare, slice an STL model and gets a gcode file I save on an SD card with several old gcode files.
I insert the card with several gcode files into the reader.
I go to Initiate card and press the wheel.
I then go to Print from SD to find the file I just stored. The file cannot be seen by the reader, only the old files.

I remove the card and again put it in the PC.
I check the file is there, it is !
I delete all files except the latest one that I tried to print. There is now only one file on the SD card.
I take the card to the SD reader, insert it and Initiate it.

Again all the old files that I deleted from the card can be seen but not the wanted file. The Reader simply don’t read the card.

I have tried to power off the printer overnight but it does not help. All the old files are still there but the wanted file is not.

What can I do ?