Repetier server can't control K8200

Hello all,

I am trying to set up a 3D print server on a Raspberry Pi, I’ve tried OctoPrint which connected and worked fine with very little input from myself. I am now attempting to try Repetier Server, after going through the config files it states that it has connected, although none of the controls appear to work.

I quite like the idea of using Repetier Server over OctoPrint as the interface is created with PHP rather than Python which will allow me to customise my set-up to my likings (my main interest is to use a 320x240 touch screen on the Pi giving print information feedback, OctoPrintLCD didn’t work for me).


For Repetier (Windows)
Check the baud rate 250000
Make sure Reset on Connect is set to Disabled

[quote=“Wrong Way”]For Repetier (Windows)
Check the baud rate 250000
Make sure Reset on Connect is set to Disabled[/quote]
Hello Wrong Way,

I’ve double checked the baud rate and it’s set to 250000, there is no option in the cfg files for ‘reset on connect’.

Also I forgot to add that the server is running Raspbian and my laptop is running Mint.


Sorry I haven’t moved to Raspberry yet

hey,i’am using repetier-server in my raspberry pi b+…i have connection problems too…firstly the printer didn’t even get “online”,but found a work around…when plugging the usb port keep the power off…while making the connection and testing the baud rate plug the power in…it would say “online” status though nothing is working in the control panel…also i have octopi server running in the raspberry and as soon as i installed and ran repeater-server,the octopi.local doesn’t let me log in my account(says that my username or password is wrong but they are both correct)…So keep in mind that running them simultaneously octopi won’t work…Moreover i’ve tried repetier-server in mac os yosemite and windows 7 with both having the same connection problem…if anyone find something tell us!