Problems with the K8048 Board

Hi Folks…

I’ve just built the above board and have checked and rechecked it to make sure everything looked okay. I’ve put in a PIC16F627-04 as supplied with the kit and powered it all up using a 12V 300mA un-regulated PSU.

The green led (ld7) comes on. so far so good - No smoke. Switching SW5 to either Run or Prog has LD9 flashing. So far so good. Still no smoke :smiley: I then put board into standby mode

I install the software onto my desktop machine and connect the made up cable as per the instruction manual (pins 3, 4, 5, 7, 8, 9). I ran the software (PIC Programmer) and got it to check COM1 where it duly detects the K8048 - Good!!

I compiled Demo1 and loaded the hex file up into PIC Programmer but when I try to write to the PIC (Controller set to PIC16F627 PIC), it says ‘No Device ID received’


I then went to this website and followed all the relevant possible fixes (except removing the resistor) but still no joy. I then downloaded the PicProg206 program and associated update to see how it faired.

When I run PicProg2006 with the K8048 compatibility function checked, it says ‘No Velleman Programmer connected to the PC’.

Anyone any ideas as to what is could be the problem. Could it be that my PSU isn’t quite up to the job. I’ve tried several 12V PSU’s that have different current rating but nothing works. Could it be the the 12v unregulated supply is too low?



My problem is the same. But i can read from pic. I cant write to pic. I tried to connect base of T4 to ground, but still doest work?


Hi, did you solve the problem as my board is doing exactly the same thing

I dont think its your PSU, I have a cheap 12V supply which actually kicks out less, and the 8048 works ok…tried this URL? - read the last post on page 3

I had similar errors come up when using a commercial rs232 cable with all pins connected and about 1.5M long.
Check my post at [ for a possible fix.

Hi guys,

I built the same kit last year and got it to work fine without any modifications. I used the running led’s demo program supplied with the kit as my first project and it worked as it should on the PIC16F627 supplied with the kit.
I am using a standard wall wart type power supply with the kit. (16V 1.5A), and a commercial RS232 flylead.

The only possible advice I can think of is to check the jumpers on your board ( the one that connects the crystal oscillator to the IC socket being programmed), or swop the PIC with another one.