Prints too small

Hello all,

My dual head K8400 is printing everything too small. A 100 mm thingie comes out at about 99.2 mm. holes are of course always too small as well by about .6 mm. Prints come out very neat, but just too small overall. Trying to compensate with horizontal expansion and hole expansion in Cura just deforms the whole design.

I also tried adjusting the belt tension, but to no effect.

Should I adjust something in the firmware?

Are there any tips on this? All help is much appreciated!

All best,

Hello @Wilco

Look like you need to calibrate your printer, to adjuste the Steps/mm for X and Y and you can also calibrate ESteps/mm for the extruder(s) …
Edit : ->

Sorry, I am French and I only have links to French tutorial for this :slight_smile: google search or translate can help …

And this wiki (no valid ssl certificate … but no virus detected for me) have some useful information on K8400

And if you don’t want to change your steps/mm from g-code or Repetier Host or the LCD screen or if the firmware doesn’t give a response to an M503 gcode, you can scale the model on the X and / or Y axes before slicing under cura.

Thank you PPAC! I will whip out my multimeter and dive in.

1 Like

This can also be the problem of defective stepper driver board for X and Y stepper motor.

Replace boards: Stepper driver board - Whadda

Velleman Support


Hello PPAC,
Thank you again for the link to the wiki.
I checked all the voltages at the upper register of the 0.89 - 0.925 V range. All except for extruder #1. I set all to be 0.924 / 0.925 but found no change in the result in the dimensions. The adjustment the extruder board did seem to solve another issue though, where the temperature of the extruder didn’t get back up high enough to continue printing after the other extruder did its part of a layer.
I must say I also added a 15 Ohm resistor to the 10 Ohm resistor on the pcb on the top, that the heater, temp sensor and coolers connect to.

I’ll try to hook up the printer to Repetier now. See what M503 says.
cheers, Wilco

Thank you VEL450. Is it a valid assumption I could switch around the stepper driver boards and see if the problem shifts?

Yes you can but make sure to turn off the power and not misinsert / shift or reverse the direction of the drivers

And for me the X and Y steps/mm is the solution for dimensional accuracy … but you have to try to find out and tell us !

For the wiki this is @raby to thank !

Have a nice day !

@Wilco, indeed as “PPAC” says, you can switch the stepper drivers to see if problem shift, or solved with replacing for that axis.

But Sometimes it happens that the “Stepping Mode” are changed due a internal defect in DRV8825 IC (Stepper driver IC). If this happens, the speed can be slower or goes faster than other stepper motors.

See info: Pololu - DRV8825 Stepper Motor Driver Carrier, High Current
The resolution (step size) selector inputs (MODE0, MODE1, and MODE2) enable selection from the six step resolutions according to the table below. All three selector inputs have internal 100kΩ pull-down resistors, so leaving these three microstep selection pins disconnected results in full-step mode. For the microstep modes to function correctly, the current limit must be set low enough (see below) so that current limiting gets engaged. Otherwise, the intermediate current levels will not be correctly maintained, and the motor will skip microsteps.

MODE0 MODE1 MODE2 Microstep Resolution
Low Low Low Full step
High Low Low Half step
Low High Low 1/4 step
High High Low 1/8 step
Low Low High 1/16 step
High Low High 1/32 step
Low High High 1/32 step
High High High 1/32 step

Changing speed / or Steps/mm can help to get it back correct, but if driver IC has an internal defect, that’s not a trust solution…

Best regards
Velleman Support

1 Like

Well, I switched around the stepper boards, and found no changes whatsoever. So either all boards are faulty, or none are.

At the moment I have doubts that the boards are the problem. Would in that case not a large object have a larger error? If the size difference is 1%, it is one mm on 100 mm, and one hundredth of a mm on 1 mm. But the error is always about 0.25 mm. So my 100 mm is 99.5 mm, and my 5 mm is 4.5 mm.

Oh, and both in X and Y. no idea about Z.

I have experimented a lot with Cura settings horizontal expansion and horizontal hole expansion, but found no solution with it. Horizontal expansion also closes the holes further, and countering this with horizontal hole expansion disforms the whole thing.

I tried connecting directly to Cura and repetier host, latest versions on OSX Big Sur. Cura can control, but doesn’t show respons on the screen, and repetier says it’s connected, but doesn’t understand the printer. So no results with gcode commands yet. Should I try a windows machine for that?

Again thank you for all advices and support.

All best, Wilco

Under Repetier, In printer connexion settings, protocol ASCII ?

Somthing like this (thanks @Wrong_Way )