Printer head crashes into bed and gouges tak and printer bed


I bought a Vertex Delta at Christmas time and have only managed about 4 decent prints with it. I built it myself and it worked perfectly printing the keychain and the PLA feed at the top of the printer, since then I’ve managed a couple of other things but few and far between.
Every time I print I try the calibration and 90% of the time the head crashes into the bed, I’ve replaced the build tank 4 times and trimmed it off. I’ve tensioned the belts and cleaned the printer head. Still the same result.
The printer head has chipped and gouged the printer bed.
It’s terribly frustrating; do you have any pointers on what I might need to do. At this point I’m about to replace the belts and strip the printer down and re-build it. I’m not convinced the piece sensors are working.
Do I need to reload the firmware? At the moment, apart from stripping it down and rebuilding it, I’m out of ideas.
Thank you

Hello @langers

You can try these steps from the Calibration Solution Guide.

Please follow the points in this guide step by step and very precisely. Check and adjust where necessary. Do this with the highest accuracy!

The assembly manuals can be found here:

Base assembly manual
Extruder assembly manual
Printhead assembly manual

I hope, this can help you further to solve your problem.

Best Regards,
Velleman Technical Support

Good afternoon, thank you so much for your helpful suggestions and general support. This problem seems to have fixed my printer bed crashing issues so I have printed the instructions and they have pride of place next to the printer to remind me every time I change the printer nozzle/head to re-calibrate.

I do have a new issue though but I will check the other threads and start a new one if necessary.

Again, thank you for everything.

You’re welcome,

Hope this guide will solve the other problem too.
If not you can also make new thread if necessary.

Best regards,
Velleman Support