Printer doesn't read SD card

I’ve assembled the printer, run the calibration but now I can’t get it to read models from the SD card. When I first tried with the SD card supplied it briefly showed the card’s directory but after a second or two the 3D models directory disappeared from the screen and turning the wheel wouldn’t bring it back. If I put the card in my PC I can see the directory is still there and has files in it.

Since then it has got worse. When I put the card in the start screen says SD Card Inserted but when I go to the menu it still says Insert SD card instead of Print from SD card. If I select Insert SD card it just shows a square icon with two dots and Main, which goes back to the main menu.

I’ve tried using a different SD card, I’ve run Scan and Repair on the SD card in Windows but this finds no errors, I’ve downloaded the keychain model file from the website and I’ve tried putting the model files in the root directory of the card. Both of the cards are formatted as FAT32, the supplied one is 4GB, the other one is 16GB.

I’ve run out of things to try so unless anyone has any ideas I suppose I must have a faulty printer.

Sounds like maybe a bad wire connection could you check the wires?
just behind the LCD

You are putting gcode files on the SD card not SLTs right?

Thank you for the suggestion. I had a look at the connectors on top of the base behind the lcd panel. They looked OK, I gave them a push anyway and when I tried again it worked. I didn’t think I had done anything, if one of them was loose it wasn’t by much but I am glad it is now working.

Of course my first attempt at printing was a complete mess so I’ll be searching the forum and probably asking more questions.

Thank you


1 Like

Yes, they are gcode files.

1 Like

I had the same problem and I pushed the wires and then it worked. But now the poblem is back and I pushed the wires and reconnected them but it still doesn’t work…

@Maks ,

The cause is maybe the problem on connector of SD-card PCB.
Reconnect the cable can help. If the problem still persists, you can ask replacment SD-CARD PC here and open a new ticket.

See the “Base-assembly” manual for mounting instructions (replacement) via link below.

Best Regards,
Velleman Support