PLA not sticking and initial blob sticking to printhead

I have the printer set up to print at 200* C and it seemed to work before.
After coming back and not using the printer for a few days, it doesnt want to stick to the bed anymore…

The filament extrusion that is done before the actual print starts just gets dragged along with the printhead and there is no fillament coming out of the printerhead after that. (Or it is coming out but getting stuck to the blob I think.)

What can I do to try and fix this? Is it my printbed being too cold? How can I fix this?

Hello @GrimZero

Have you clean your buildtak with glass cleaner or isopropyl alcohol (an alcohol without a lubricating agent …)
Also just fingerprints can disturbe adhesions … (best to clean every time befor printing )
And lightly scrap and / or lightly sand the buildtak to create micro adhesions.

This should work if you don’t have a partially clogged nozzle, and you have sufficient flow with the correct nozzle / tray distance.

You also have to clean the nozzle from time to time with a paper towel when it is hot, the paper towel have to come back clean.

Have a nice day !

@PPAC I have not cleaned it with that. Tho I did wipe off some dust that had formed, I will grab some alcohol and do that. (I did use hairspray to try and get the buildtak surface more sticky, was that a bad call?)

I assume it best to use small grit sand paper for best result, which I dont have, so I ll need to go get some.

I have tried printing multiple times, and each time there is filament coming out, so I doubt it would be clogged right now.

The hairspray will end up leaving …
Start by degreasing as well as possible!
Yes, you should not sand too much, we try to have micro adhesions so as not to damage the rather expensive buildtak too quickly.

To verify that you do not have a partially clogged nozzle, measure the diameter of the extruded filament. it had to be very slightly larger than the size of the nozzle. So close to 0.35 mm but not below.

1 Like

@PPAC I will try without sanding, and cleaning with the alcohol. So I can avoid damaging it if I dont have to. Additionally, I might order a second buildtak as a backup to see if that fixes it.

1 Like

Change buildtak only if it cracks and pieces are left.
Reread my last messages, I added some info.

Too soon but better to know :
When you have a (too) good adhesion of the buildtak, use a blunt / dull blade or a spatula rather than a sharp cutter or you will risk damaging / cutting the buildtak …

Have a nice day !

1 Like

I use one of those paint remover tools for scraping that is pretty blunt. I suspect I would be fine on that front. Thx for the tip tho.

I tried the alcohol and cleaned it thoroughly. that had little success. After that I tried with light sanding using a kitchen sponge (rough side) seemed to make the adhession do ok.

wasnt perfect right off the bat, but im doing some more cleaning and hopefully I can get it to adhere properly :slight_smile:

Thank you for the tips!

1 Like

Also in Cura you can for the first layer use a greater flow (like 105% to 110%) and a highter temp. (like +5°C) than the other layers, this will ensure best adhésion …

1 Like

I recleaned and sanded the surface and now its working perfectly so far. Will update after a bit of time has passed and this print finishes. I hope I get little to no warping!

You use cura? I was under the impression we needed to use the repetier software that is made for the printer. Do they use the same GCode?

To avoid warping use a brim !
Cura is a slicer like Repetier Host and many other …
You have to well select / configure your printer (set the G-code flavor for Marlin firmware) and filaments spécification, not so simple for a beginner…
Recent slicers are realy look a like … but under Cura some plug-in like Arc-Welder do some miracle for curves movements …
I steel use repetier host to visualize g-code ( printing speed, duration …) or control my printer when needed.
But i like that almost all slicing paraméters are in a single list under cura … but the placement controls of an object before slicing is not as good as in Repetier Host

The print I am doing right now seems to be working sliced with repetier, I might look into cura tho.

if I slice in cura and load into repetier, I should be able to verify the gcode export and make sure it has supported code.

Not sure what arc welder is, but its also worth looking into

g-code is a so basic / simple control protocol thats it’s hard to create unsuported g-code except using spécial command …

for arc-welder info. see :

I may have wrongfully assumed there are different gcode versions for different printers.

I’ll need to look into it, its a trial and error thing to figure out the best way to print in any case :slight_smile:

no you are right, but this is more due to diffrent firmware marlin vs …
or usage like for CNC firmware grbl

Sorry i begin to be very tired … it’s time for me to go to sleep !
But just to brag my last printing of the day :

Hoping you will get some better printing with you Delta ! have a nice night !

1 Like

In case of print quality issue take a look to (or bookmark it for later) :

Have a nice day or night !