PCSU200 doesn't work

I recently bought a PCSU200 and downloaded the software PCLAB200. The first time I tried it everything worked fine, but the second time I can’t measure anything.

I have tried everything, such as uninstall both drivers and software, tested different USB ports, different PCs, but nothing works. When I try to calibrate communication fails and the Calibration.log says:

Calibration results:

CH1 offset at 3V/div : 161 OK
CH2 offset at 3V/div : 161 OK
CH1 offset at 1V/div : 101 FAIL
CH2 offset at 1V/div : 101 FAIL
CH1 Y-position low 53
CH1 Y-position mid 53
CH1 Y-position high 53
CH2 Y-position low 52
CH2 Y-position mid 52
CH2 Y-position high 52

I’m running Windows 10 and keep it updated but get the exact same error when trying Windows 7.

I’ve seen other posts from years ago with the exact same problem, but can’t find anything to suggest what the solution is.

What can I do? Return it?

You can return the PCSU200 for repair via your local Velleman dealer or direct to:

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere