PCSU1000 - problem with driver using Win 7 64bit

I got a new package PCSU1000. The installation worked until I started using the newest pclab2000se_4_07_setup.exe. Using this new software from the Velleman webpage I see a problem. The PCSU1000 device shows up in “Gerätemanager” but unfortunately there is this yellow sign showing a problem. The FTDI driver not working has a date 28.10.2015 and version

When I am deleting this software and go back installing the older version pclab2000se_4_05_setup.exe there is no problem. The FTDI is working then and has an old date 17.2.2009 and version

The same problem is there on a second laptop I tried using pclab2000se_4_07_setup.exe. The same yellow sign !

There is no separate driver available from the Velleman site.
May be there could be available one from Velleman UK. But I am not able getting it from them. They only seem to work for England and so.

So how to install a functioning newer driver?
I would be happy if someone could give an advice doing so.

Any helpful hint appreciated ! Thank you !

If the yellow sign is under “Other devices” in the device manager, it is OK.
Here a screenshot:

When you check the driver of the PCSU1000 under “Universal Serial Bus Controllers”, is there any error info in the “Device status” window?

The driver is included to the setup package.
After the installation the driver is found in the folder:
C:\Program Files (x86)\Velleman\PCLab2000SE\Drivers\PCSU1000

In this thread there is some more info: Latest PcLab2000SE for PCSU1000 kit on a Windows 10 x64 PC

I had several trys now on 2 different laptops. Both Win 7 64bit. Unfortunately at the moment no one of those works properly with PCSU1000.

The supplied CD does not work because its a 64bit system.

The newer driver does not work because of this 4.07 software problem.

When I connect the Device and run PClab2000SE there comes up a message “No hardware response”.

There is this yellow sign there - please see the pictures ! treiberproblem_geraetemanager2|408x450 treiberproblem_geraetemanager1

Are there any hints getting this solved?

one picture seems be still missing. I do a retry ! treiberproblem_geraetemanager2|408x450 .

Thank you for the reply.

I think there is no problem using version 4.05 on Windows 7.

These are the updates done in version 4.07:

  • PCSU1000: Calibration procedure slightly modified.
  • Added Windows 10 driver support.

Thank you very much so far. But 4.05 does not seem to work any longer now after those several trys. Thats not good at all. Would be much better to find a way getting back to a working solution.

The other problem that I had seen was that the calibration took extremely long time when started from the pull down menu. May be it did not stop the scope before? I do not know. I had to kill the application with the task manager then.

Is the driver version successfully installed?

This problem may be fixed by installing version 4.07. Still maybe using the older driver version.

“Is the driver version successfully installed?”

do you mean the FT245 driver?

on the delivered CD I can find a folder named PCSU1000_driver. Inside this there is ftdiunin.exe, ftd2xx.inf etc. According to d2xx release info.txt this is version 1.06.20 from 2004. This was the driver I was using first. Unfortunately it does not seem to help anymore now.

On the CD also is a PC-lab2000SE_V3.03 which I did not use yet.

Unfortunately the CD stuff did not work using Autorun. Therefore I first had a look at the Velleman page for newer drivers.

On this page I did find the pclab2000SE_v4.07_setup.exe. And I also had the older one pclab2000SE_v4.05_setup.exe.

I had a working PGCU1000 and tried adding the PCSU1000 to that. The first time this worked. May be because there may have been another FTDI driver for Arduino stuff.

The problems began when I tried using pclab2000SE_v4.07_setup.exe and the uninstall. Now nothing works.

I also tried a second and also a third laptop - all with the same Win 7 64bit. On no one of those I am able to bring this to life !

Its a pity. But I really need a solution there ! I will not change to Win 10 now.

On the third system I now installed PClab 2000SE v4.05. When I connect the device there comes a device PCSU1000 with a yellow sign at “andere Geräte” and not under “USB-Controller”.

“No hardware response” says the software.

When I try “Treibersoftware aktualisieren” giving the path of the folder PCSU1000_driver this does not work. There comes a message “PCSU1000 konnte nicht installiert werden. Die Treibersoftware wurde nicht gefunden. Wenn Sie den Hersteller kennen können Sie nach Treibersoftware suchen”.

Of course I tried finding such driver software on your site but unfortunately there was found none. It seems to be put inside the pclab2000SE_v4.07_setup.exe.

So how to proceed here? I am not sure now what to do next. It does not run on any on those 3 systems !

If you double click the driver name “PCSU1000_Oscilloscope” in the “USB-Controller” section of the Device manager, does everything look OK with the driver?
If yes, this indicates the driver is properly installed.

Have you tried with other USB cable?

Yes, it is included there and it is installed automatically during the software v4.07 install.
After the software installation the driver files are found in the folder:
C:\Program Files (x86)\Velleman\PCLab2000SE\Drivers\PCSU1000

It seems you used the the folder PCSU1000_driver on the CD.
If you want anyhow manually try to update the driver, please give the path to the folder:
C:\Program Files (x86)\Velleman\PCLab2000SE\Drivers\PCSU1000

thank you very much for your valuable hints !

I now tried installing 4.07 on each of the 3 systems.

On the last one this now worked. The difference seems to be that the installation exe file behaves different. On the third system it installs the FTDI driver and 2 times a pop up will occur that one has to answer with the lower answer. Then both drivers are then there and no yellow sign.

So this is the way it should work.

Unfortunately it does not work the same way on the other 2 laptops.

On those there are not coming up those 2 pop up windows and no FTDI driver seems to be installed properly. The software only shows the PCGU1000 driver to be installed. On the PCSU1000 there is this yellow sign then there and no communication possible.

At all 3 systems I started the .exe as administrator.
But why does it not work all times correctly?

When I double click on the functioning one there comes up the message “Das Gerät funktioniert einwandfrei” and on the others there comes “Die digitale Signatur… kann nicht überprüft werden”. In the “Treiber” tab the FTDI is given correctly but it does not work. The installation time also had been much shorter. Why is this such different?

Its does not seem to be a problem of the USB cable. I am using always the same cable. I could of course also try another one.

Thank you for the hint of the driver place: C:\Program Files (x86)\Velleman\PCLab2000SE\Drivers\PCSU1000.

When I am trying to reinstall the driver the software tells that the driver is already in place. But why then does it not work correctly?

When I am deleting this driver there comes up a “PCSU1000” in the Gerätemanager together with a yellow sign. Unfortunately reinstalling the driver this way fails with a message “Fehler beim Installieren der Treibersoftware für das Gerät”. “Es wurde Treibersoftware gefunden, aber ein Fehler aufgetreten”. “Die digitale Signatur… falsch signiert oder beschädigt”.

I do not hope that it will be necessary reinstalling the whole Win 7 64 bit getting rid of this?

Do you know a procedure getting this fixed?

It seems these two PCs do not accept the digital signing of the PCSU1000 driver.
Anyhow you have now one working system to run the PCSU1000 oscilloscope.

With the two problematic PCs you may try the manual driver installation in following way:

  • First delete the current PCSU1000 driver.
  • Then you have to disable the driver signature enforcement:
    Press F8 when Windows is booting up until you get the Advanced Boot Options menu, then select “Erzwingen der Treibersignatur deaktivieren”.
    Here you’ll find instructions in German:
    Windows – Treibersignatur deaktivieren

Then try to install the driver located in the folder C:\Program Files (x86)\Velleman\PCLab2000SE\Drivers\PCSU1000

yes. This works. Unfortunately on this system now the PCGU1000 does not work. This only works on the other system. Its a pity !

I had a look at the VB program for PCSU1000. This also works !

Unfortunately I have not been able bringing the VB program to a full success with the PCGU1000. The generator works using the 4.07 software. The FPGA is loaded and the red LED then comes up.

Using the VB demo program this can be run. It also seems to load something. But the red LED does not come up. No signal on the output to see. Is there a chance getting this going?

“Then try to install the driver located”

I will have a try ! Thank you !

I really like those 2 systems and wrote 2 little books for me about how to install and use together with schematics. Its a pity that I still do not know exactly how to overcome this trouble. I hope there will be a happy end with both systems running with the same laptop.

You can try an updated version of the FGULINK.DLL software package available here:
The function generator software FGU.EXE of the package is updated to version 5.
There is also a demo software FGULink_demo.exe included into the package to test the operation.

In this thread there is some more info: PCGU1000 - FGULink.dll in W10

Thank you very much for this ! It now works well !

Are there other programming samples like that for PCSU1000 and PCGU1000 available for download? I use VB at the moment but also could have a look at Delhi, C, C++ or so.

Is it possible getting the schematics of the PCGU1000-6 board that I have. On the CD there were only the files for PCGU1000-5.

Thank you very much - this worked for me. The first laptop is now able running both devices. This really helped much !

Is it possible somehow decoding SPI from the wave form data? Is there a software for this?

What about Pure Basic? Could this also be used instead of VB? Did anyone do a running example using Pure Basic for those 2 Velleman devices? The advantage could be that PureBasic produces small exe files without need for additional library files or dll.