Pcsu1000 how to use with 64-bt Windows 7

I have attempted every way I know how to get my new pcsu1000 to be recognized by 3 different computers all running Windows 7. Nothing is working to get the driver installed.

Any help would be appreciated.

On this site you can download the driver for Windows 7:
velleman.eu/support/download … 1000&type=
Download and install the driver:
“PCSU1000 USB Driver
for Windows XP / Vista / Windows7 (32-bit and 64-bit)”
When installed, in the Device Manager you should see:

Thanks for the information, it worked.


I have the same problem. I run Windows 7 64 bit. I downloaded that file but can find no driver called PDSU1000 USB Driver in that directory. Where is the driver hidden?



Extract the downloaded file pcsu1000_driver_rev1_06.zip and you’ll get the subdirectory PCSU1000_driver in the directory pcsu1000_driver_rev1_06.

Here you can download the instructions how to install the driver in Windows 7:

Here you can download the instructions how to update the existing driver: box.com/shared/66aei7j31s

The instructions are for other oscilloscope - you can use as reference.

Hello again

Thanks for a very fast and accurate reply that did the trick admirably. The PCSU 1000 seems to be a fine instrument.

Thanks again


I just bought a new PCSU1000 and I run WIn7 64 bit mode. The driver for FTDI seems to be running well as visible under the PCSU1000_Oscilloscope properties in the device manager.
When running the PCLab2000SE software, it seems to detect I have a PCSU1000 on USB. When I click OK, the software tells me it is now running in Demo mode. Choosing the Options|Hardware Setup and clicking on the PCSU1000 gives me an error : Could Not Open the DriverLinx driver. Please run INSTALL_DRV.EXE. I had done that and rebooted my desktop several times. But still the same problem.

Am I missing something ?
Thanks for helping.

There is a workaround:
In the PcLab2000SE start screen select PCSU1000 and PCGU1000.
Then click the OK button.

For more details please see: viewtopic.php?f=10&t=2202

Thanks a lot. That did the trick.